cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Inventor BoM doesn't match WTPart structure

SOLVED
Regular Member

Inventor BoM doesn't match WTPart structure

We noticed that amended quantities in Inventor BoM don't transfer over to the WTPart structure.

In the example below the qty of M0030387 has been modified in assembly but the WTPart BoM shows the qty of model occurrences (2) instead of the desired qty (13).

Inventor BoM qty changes.png

Has anyone come across this before?

 

Regards

Rob

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Inventor BoM doesn't match WTPart structure

PTC R&D informed that modifying quantities in Inventor BOM Dialog Box changes the value from "Calculated" to "Static". A Static value has no effect on the true CAD assembly structure. Only CAD assembly structure occurrences as shown in the Inventor Model tree are taken into account by the WWGM, not any Static value set in the BOM Dialog Box.

View solution in original post

5 REPLIES 5

Re: Inventor BoM doesn't match WTPart structure

@rhart 

We've experienced this before.  I expose the 'built from CAD' column in my BOM view and review the Reference designator columns.  Often this leads me to the source of the issue.  Often I've found one part or the other didn't 'build' correctly OR the Owner Relationship wasn't applied.  There are (as you know) many variables.  🙂

James
Windchill 11.0 M030
Inventor 2019

 

Built_CAD.png

Re: Inventor BoM doesn't match WTPart structure

Thanks for your reply @JHall, I've added the columns, does it give any indication what's happing in this case?

 

Inventor BoM qty changes - columns.png

Re: Inventor BoM doesn't match WTPart structure

@rhart 

What I see is that the parts are built from the CAD object and that there are 2 in the assembly.  BUT, what is the symbol at the top?  Has this been checked in?

 

symbol_.jpg

Re: Inventor BoM doesn't match WTPart structure

Yes, it is checked in @JHall 

The little shield symbol means there's a security label on the part, we apply them as default for every part.

sl.png

Re: Inventor BoM doesn't match WTPart structure

PTC R&D informed that modifying quantities in Inventor BOM Dialog Box changes the value from "Calculated" to "Static". A Static value has no effect on the true CAD assembly structure. Only CAD assembly structure occurrences as shown in the Inventor Model tree are taken into account by the WWGM, not any Static value set in the BOM Dialog Box.

View solution in original post

Announcements