cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Is there a way to send Creo parameters to PartsLink?

SOLVED
Highlighted
Regular Member

Is there a way to send Creo parameters to PartsLink?

One of our business units has Creo parameters which are basically classification attributes.

They want to be able to send these attributes to PartsLink on a save of the Part from Creo to Windchill (using Auto-Associate).

I don't see any options within Windchill or PartsLink to enable something like this to occur.

Does anyone know if this is even possible or are we going about this the wrong way?

Thanks in advance for any advice.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Is there a way to send Creo parameters to PartsLink?

If you associate your CAD to a WTPart with any of the Build Rules that push attributes (Owner, Contributing Image or Contributing Content), then as long as the Parameters are designated in CAD then the CAD attributes will be pushed to the WTPart (whether you like it or not!). Only string and floating point number attributes are supported, so the actual classification attribute cannot be passed without customization. There was at least one customer that had done something there using the Folder location from CAD, but there is nothing Out Of The Box. The fact that Unit type attributes cannot be passed is a severe limitation, it would be really beneficial to be able to drive certain sizes using a parameter and have that automatically passed (accurately) to the WTPart. I am hopeful that will get fixed in a future release, it seems too obvious to keep ignoring.

If the attributes in CAD have a different name than the Classification Attributes then you have to add them to the Attribute Mapping tab, this is available when you select the Workgroup Manager CAD Document type on the Type Manager tab of the Windchill Type and Attribute Manager.

E.G we have the CAD attribute "MATL" mapped to "MATERIAL SPECIFICATION" for WTParts/Partslink.

One other and very important consideration is that if you have constraints applied at the classification node, like an allowed value list for a string attribute. Then any Parameters you are passing from CAD into Attributes on the WTPart have to also meet those constraints, otherwise the CAD Checkin fails because the Build of the WTPart fails. I have not experimented with 10.2 yet, but definitely at 10.1 there is no system supported way to keep these lists synchronized, so you just have to carefully co-ordinate updates between CAD and Partslink nodes.

Hope this is useful,

3 REPLIES 3

Re: Is there a way to send Creo parameters to PartsLink?

Hello Zack.

PartsLink Classification is basically for WTParts and is not available to  be applied through designated attributes. This functionality is not available Out of the Box in Windchill. When you do a check-in with auto associate you do not get a prompt to classify it.

It is good to check the feasibility of building a customization around auto associate and refer it in "Custom Class for Auto Associate Part", and use Creo customization to read the attributes and pass it on. Just thinking out loud here.

Thanks

Binesh Kumar

Barry Wehmiller

Re: Is there a way to send Creo parameters to PartsLink?

Thanks for your reply Binesh.

We try to avoid any customization, but I'll take a look into something like this.

Have a good one.

Zack

Re: Is there a way to send Creo parameters to PartsLink?

If you associate your CAD to a WTPart with any of the Build Rules that push attributes (Owner, Contributing Image or Contributing Content), then as long as the Parameters are designated in CAD then the CAD attributes will be pushed to the WTPart (whether you like it or not!). Only string and floating point number attributes are supported, so the actual classification attribute cannot be passed without customization. There was at least one customer that had done something there using the Folder location from CAD, but there is nothing Out Of The Box. The fact that Unit type attributes cannot be passed is a severe limitation, it would be really beneficial to be able to drive certain sizes using a parameter and have that automatically passed (accurately) to the WTPart. I am hopeful that will get fixed in a future release, it seems too obvious to keep ignoring.

If the attributes in CAD have a different name than the Classification Attributes then you have to add them to the Attribute Mapping tab, this is available when you select the Workgroup Manager CAD Document type on the Type Manager tab of the Windchill Type and Attribute Manager.

E.G we have the CAD attribute "MATL" mapped to "MATERIAL SPECIFICATION" for WTParts/Partslink.

One other and very important consideration is that if you have constraints applied at the classification node, like an allowed value list for a string attribute. Then any Parameters you are passing from CAD into Attributes on the WTPart have to also meet those constraints, otherwise the CAD Checkin fails because the Build of the WTPart fails. I have not experimented with 10.2 yet, but definitely at 10.1 there is no system supported way to keep these lists synchronized, so you just have to carefully co-ordinate updates between CAD and Partslink nodes.

Hope this is useful,