cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

May I know how to configure the host to communicate with the windchill virtual image? Thanks.

SOLVED
Level 5

May I know how to configure the host to communicate with the windchill virtual image? Thanks.

I installed windchill in the virtual machine. I can log in windchill inside of virtual machine. Host name is vm-windchill. Ip address is 192.168.72.132. Windchill address is http://vm-windchill.localdomain:8080/Windchill/.

On the host machine:

Added the line:

192.168.72.132 vm-windchill.localdomain

into the hosts file.

I can ping vm-windchill.localdomain from the host machine. But when I open windchill from the host machine, it says Internet Explorer cannot display the webpage.

Someone can help me, I will appreciate it. Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: May I know how to configure the host to communicate with the windchill virtual image? Thanks.

If you're able to ping the Windchill machine but not hit it from a web browser, then you could be running into a firewall issue. Try disabling the firewall on the Windchill VM, and then see if you can connect from the host machine.

6 REPLIES 6

Re: May I know how to configure the host to communicate with the windchill virtual image? Thanks.

Are you able to get to the Apache page? http://vm-windchill.localdomain:8080? Do you see any attempts from the client to connect to the server in the Apache access log?

Re: May I know how to configure the host to communicate with the windchill virtual image? Thanks.

Two things for our 10.2 installation: httpd.conf and wt.properties.

In httpd.conf, set ServerName to [VM]:[port]. For example:

ServerName vm-windchill.localdomain:8080

For wt.properties, use the command:

xconfmanager -s wt.server.codebase=$(wt.webserver.protocol)://[VM]:$(wt.webserver.port)/$(wt.webapp.name)

For example:

xconfmanager -s wt.server.codebase=$(wt.webserver.protocol)://vm-windchill.localdomain:$(wt.webserver.port)/$(wt.webapp.name)

You might need to escape special characters. This also assumes wt.webserver.port=8080.

I think Lori is right, this is probably an Apache issue. But once you get that taken care of, Windchill might still be confused if you don't set the property in wt.properties. If you're lucky and Windchill doesn't get confused after setting the property, then at least you'll probably notice the VM name automatically removed from the URL in the address bar, and reverting back to the hostname.

This was our experience anyway...

Re: May I know how to configure the host to communicate with the windchill virtual image? Thanks.

Thank you so much, Lori,

I could not get to the Apache page from the client (the Host server), and the attempts from the client(Host server) to connect to the windchill server( the virtual machine) in the access log. Any thoughts? Thanks!

Re: May I know how to configure the host to communicate with the windchill virtual image? Thanks.

Hi Ben,

I tried to modify the wt.properties file and and httpd.conf as your mentioned. But I still could not access the windchill from the client (the host server). May I know what I can do more? Thank you so much!

Highlighted

Re: May I know how to configure the host to communicate with the windchill virtual image? Thanks.

If you're able to ping the Windchill machine but not hit it from a web browser, then you could be running into a firewall issue. Try disabling the firewall on the Windchill VM, and then see if you can connect from the host machine.

Re: May I know how to configure the host to communicate with the windchill virtual image? Thanks.

Chris,

Thank you so much, After disabling the firewall on the VM, I can login windchill in the host server. Thanks!