cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Missing something - Windchill Attribute creation mapped to ProE

Highlighted

Missing something - Windchill Attribute creation mapped to ProE

Tried half dozen different ways but I just seem to be missing something in regards to attribute creation. The steps I just tried were:



  1. Select “Site”--> Utilities--> Type and Attribute Manager

  2. Click tab Attribute Definition Manger--> clicked New Organizer--> replaced com.acme. with PROE_ATTRIBUTES

  3. Click on new organizer--> clicked “New Attribute”--> entered VENDOR for the name--> and String for data type

  4. Click on tab Type Manager--> click on EPM Document--> edit--> click on tab Attribute Mapping--> click Add Mapping

  5. Expand PROE_ATTRIBUTES pick VENDOR and click “Select

  6. Double click on the empty Mapping field and enter VENDOR

  7. Check-in EPM Document--> close Type and Attribute Manager

  8. Launch ProE--> create a new file--> create and designate apptribute named VENDOR--> save file

  9. Check-in the file--> successful

  10. And here is my problem, when I check the Event Manager I get the conflict “Incoming attribute(s) VENDOR ignored as they are not part of type definition”

1 REPLY 1

Missing something - Windchill Attribute creation mapped to ProE

You ahouldn't need to map anything if the attribute in Windchill has the same name as the parameter in Pro/E.

Also I think you need to go one more level down from EPM Document:

Type Manager:
EPM Document > Workgroup Manager CAD Document > Edit (button)
Template (tab) > Highlight "Attribute Root" > Add Attribute > VENDOR > Save > OK > Check in Workgroup Manager CAD Document

Mike Foster
ATK