cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Modified OIR not being utilized

BenLoosli
23-Emerald I

Modified OIR not being utilized

I have made a copy of the Part and EPM Document OIRs and made changes to the lifecycle used in them from basic to my customized lifecycle for parts.

When I create a New Part in a workspace, it gets created but uses the two-phase lifecycle instead of my own. I am assuming that this uses the Part OIR, but maybe not and that may be driving the issue.

Same when I create a New CAD Document, which I assume uses the EPM Document OIR.

 

If these are not the right OIRs to modify, could someone point me in the right direction?

 

Windchill 11.0 M030 CPS16

2 REPLIES 2

Downloading the composite rule might help. If you have WTPart and SubTypeWTpart, when creating an object of SubTypeWTPart Windchill will look at OIR for SubTypeWTPart, if it does not find anything at any context level, only then will it look at OIR for WTPart at lower context levels. Start by downloading the composite OIR to make sure what Windchill is using.

BenLoosli
23-Emerald I
(To:yadavankur)

We found the problem.

When I created the OIRs at the org level, it also created a copy of them at the product level. I did not do them at that level, but there they were. Disabled the product level and Site level OIR's and I know get what I expect.

 

Has anyone else seen the system create copies of OIR's at the product or library level when creating new ones at the Org level? Maybe I need to open a call with PTC to see if they know why?

 

Windchill 11.0 m030 CPS16

 

Announcements