Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Recent Chrome Update Possibly Affects Windchill


Recent Chrome Update Possibly Affects Windchill

This is more of a post letting others know what I encountered today with my Chrome-Windchill connection, but if anyone knows what is going on that would be great to know.  It seems that Chrome recently updated their browser, mine is showing 83.0.4103.97, and I am now having issues with it.  I have cleared all the history out of Chrome and it still has the issue.  The issue has been seen across multiple computers, is that during the creation of a CN, when you go in and edit the task during that creation a blank window pops up with the spinning circle of death.  I am on Windchill  The only error that is in any of the logs is:

2020-06-05 07:51:47,667 ERROR [ajp-nio-] com.ptc.windchill.enterprise.change2.tags.ChangePropagationTag <USERNAME> - action oid was null


I have opened a support call and am waiting to hear back from them.


I don't know if anyone else has seen this yet or not.

123 REPLIES 123
5-Regular Member

So Far - My Work-Around (Clearing Cache from within Chrome) has held fine. I am on my own laptop/I am administrator on the laptop without much IT Oversight.  Connecting to Cloud Windchill Systems (AKA not on a company network)

I have been switching between Development, Test, QA and Production Servers.

Primarily Making Workflow Template Changes.

But Creating Change Notice/Change Activities as well.  


Majority of Users are NOT reporting any issues and have continued to work.  Creation IT can not roll back the Chrome Build.  And they are suggesting Edge for this Users Affected.  The Heavy users have not seen any issue yet.


But a Ticket with PTC has been opened so that PTC can give formal response.



5-Regular Member

Note: For the Thread:  PTC Did create an Article to Track the Issue:   CS326191

Nothing in the Article Yet - Just that it is with R&D
Regarding My Customer:
* The Business Admin is reporting what others say - that clearing cache only works one time... and then issue comes back.. So he switched to IE.  (Can not use Edge as already Edge updated to Chrome Version and has same issue)
* I have still not seen the issue come back yet since I cleared Control Panel/Internet Option Cache and then the Chrome Cache..
* Majority of Users are not seeing the Issue at all. (Though Customer redirecting all traffic to Internet Explorer) to avoid new IT Tickets.

Sounds like you are lucky!  I still have the problem even after:

  1. Clear Cache in Chrome and Chromium Edge
  2. Clear internet Options Cache from control panel
  3. Still didn't work so Cleared Chrome cache again...didn't help.


not sure why it works for one but not the other.  I guess the users it works for can be glad! 😀

"When you reward an activity, you get more of it!"

The TSE handling my case pointed me to the article you referenced.

SPR 10134786 has been logged by R&D.

Could please somebody verify if they still can create a new subtype in the Type and Attribute Manager? E.g. create a subtype for a WTDocument. I have the same spinning circle.

I belief the Chrome problem has something to do with the lightbox.




Yes, you right. I cant create it in new build of chrome.


Many light boxes (window in window) are involved.


Also the creation of new sub-type is involved as new attributes and many others things.



Yes, I experienced this yesterday. Cannot create new Reusable Attribute in latest version of Google Chrome for Windows 10 on Windchill 11.1 M020 CPS11.

A brief update - the R&D team has been able to confirm it is an interaction between Light boxes and Chrome 83.0.4103.97.  The team is trying to dig in more.


Testing with the latest Chrome branch (Chrome Canary 85) we have not seen these issues reproduced.


What is Light boxes?


I had the same question.

This is from Wikipedia:


Lightbox is a JavaScript library that displays images and videos by filling the screen, and dimming out the rest of the web page. [1] The original JavaScript library was written by Lokesh Dhakar. [2]


Here is a link to the Wiki page:


It is frame window inside browser window, it could be created by javascript.

Anyway this window is opend if you want to create attribute in a Windchill type&attributemanagement and others many places as change management wizard in the Windchill.


Screenshot is attached






Hello Jeff,


I tried the dev version of chrome 85 and the latest build also has the issue.

 I attached also video where the history had been cleaned.




Thanks. Will update after comparing this version with the build that R&D validated against.

Same issue here 😞 Using Windchill 11.0 M030 CPS 14 and Edge Chromium 83.0.478.50.

And also see the issue when using Chrome version 83.x.x.x


Funny thing is, we just moved all our users from Internet Explorer to Edge, as the performance is much better.


I really hope there will be a fix to this other than waiting for Windchill 12 or some unknown future Edge/Chrome version.



This account was related to my previous PTC PTC Account.
I am now at user - id 555176

We'll need you help in reproducing the issue because we're unable to. I'm looking for a volunteer to work with our R&D folks - may be a webex where we can both exchange what we observe and figure out how to reproduce it on a PTC system.




I can.

I also have a case opened already for this issue: C15427851

@DeviVijayakumar, I have C15432860 open. Feel free to reach out if you need me to reproduce the issue.

This account was related to my previous PTC PTC Account.
I am now at user - id 555176



I'm also open for webex session and reproducing the issue.


Case number C15431166



This isssue only persist on non SSL layer (HTTP) WIndchill URL.

With SSL Layer (HTTPS) WIndchill URL there is no problem occuring..


How do we switch to HTTPS?




Can you please explain to the community how is possible that PTC has decided not to fix in 11.1 while R&D cannot reproduce the issue???? Seems illogical to me.... If you cannot reproduced it, how can you make that decision?

See CS326191 or attached screenshot.




It doesn't say they won't fix 11.0 or 11.2 through.

R&D has been working on this with priority and has identified a potential fix now. The fix is currently being tested.  After adequate verification, we'll look into back-porting to older supported releases based on technical and other considerations.

@DeviVijayakumar - Will this be a patch instead of a CPS?

Chrome just rolled out a new version Monday June 15th 83.0.4103.106

It appears to work for me. It automatically updated to this version when I checked the version I was running. 

I got this message when checking the version


After restarting Chrome it now says this. 




I tested the new version.

For me, it worked only the first time (e.g. set state on resulting objects).

After that doesn't work anymore...

You right.

The next build behaves same way as the previous one in my case.

The first try to open the lightbox window worked, then it doesn't. 

Same behavior if you clear the cahced files. 

I tried the new version, customer tried new version of chrome with same issue.

Chrome version 83.0.4103.106



Hello All,


An important note: 

Chrome issue(Adding new attributes, global attributes, Set state in the CN DetailPage, Editing the ChangeTask in edit wizard of CN and there would be more places with the popup inside window.)

This isssue only persist on non SSL layer (HTTP) WIndchill URL.

With SSL Layer (HTTPS) WIndchill URL there is no problem occuring..





Very good point.

I tried it with customer where the HTTPS (SSL) is configured and the issue is still reproducible.

Even the cache is deleted. Chrome version 83.0.4103.106

Windchill 11.0 M030 CPS11


Next test with Windchill with HTTPS it works Chrome 83.0.4103.106



OK then in my side Windchill 11.0 M030 CPS17 with both layer of SSL(http & https)

it is working in https and not http..