cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Resolve WTPart creation issue for drawing

Alexandrite

Resolve WTPart creation issue for drawing

Hi, We have a setting in windchill that drops the file extension from the CAD object when you create WTPart which is fine for the Model however that also drops the extension from the drawing. We then get checkin errors as the drawing is trying to create another WTPart that is not unique. Is there a setting I should be using that sees the drawing as additional content in the WTPart?

 

example; 1234.prt when checked in will create 1234 (WTPart)

1234.drw when checked in is also trying to create 1234 (WTPart)

4 REPLIES 4

Re: Resolve WTPart creation issue for drawing

The system should not create WTPart for drawing. There is only a "calculated" link that is display in the UI from the drawing to the WTPart associated (though owner link) to the 3D model.

Florent ROUSSEL
www.4cad.ca

Re: Resolve WTPart creation issue for drawing

The error is not with the WTpart, but the number of the drawing.

1234.prt is created and checked in as 1234 with a new Wtpart of 1234.

When you go to check in the drawing 1234.drw, your settings try to drop the extension from the number and you get 1234, which already exists.

I have the same issue and have not figured out a work around except to turn on/off the drop extension depending on which file type I am checking in.

I have my personnel preferences to drop the extension because I seldom create new drawings. I do create a lot of family table members for standard parts.

PTC needs to not error the second file, but if the 1234 number file exists, let the 1234.drw go in as is. This also means that users MUST learn to check-in their models (parts/assemblies) before trying to check in the drawing. Along these lines, PTC should not allow a .prt and .asm to have the same number; 1234.prt and 1234.asm should not be allowed, but 1234.drw is ok.

 

Re: Resolve WTPart creation issue for drawing

I agree the system should not try to create wtpart for drawing just the calculated link. Do you know how to change the settings to make that happen?

Re: Resolve WTPart creation issue for drawing

thanks Ben, I know what you are saying is true. Everyone who is using WTParts must have experienced this at some point unless they have a setup that addresses this. I am trying to work out is there a preference that can drop WTPart creation for drawings or make some other association between the drawing and the existing WTPart.

 

Also FYI this has been an open call on my support provider for some weeks and they are doing little to help.