cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Save command also creates drw

GiFra_Label
8-Gravel

Save command also creates drw

Hi,
I can't be able to find what lets create the drw file when I make a new prt and save it.


I want the creation of drw file not always because I have many part that are only on the undercard.

But I dond' find the Creo Option that lets it but I don't think it's a Creo "matter" because in stand alone mode it doesn't. It does only with windchill.

 

How can I do?

1 ACCEPTED SOLUTION

Accepted Solutions

I've fixed it.
First of all, the problem accoured only when I work with the configuration of Creo that starts linked to WC. If I start the configuration "stand alone" (that "takes" other files) I haven't problems.
It seems that the problem was the presence on WC of the drawing of the start part (template part). Each time I create a new .prt it create also its .drw.
I deleted the start part's drw and now it creates the drw no more.

View solution in original post

6 REPLIES 6
TomU
23-Emerald III
(To:GiFra_Label)

Take a look at the config option 'rename_drawing_with_object':

 

TomU_0-1651061768678.png

 

 

I've setted this option on "both" for Creo Stand Alone and linked with Windchill.
But it happens only with WC. So I don't think that this is

TomU
23-Emerald III
(To:GiFra_Label)

It works in standalone too, but the drawing must be present in the working directory and it must have the same name as the model.

For information, in Creo 8 you now have the option to set the drawing name according to the CAD model automatically when creating a new drawing.

So the workflow would be to create the model first, and then create a new drawing when required using the checking the Use drawing model file name option highlighted below. The drawing will automatically have the same name as the model.

 

 2022-04-27_16-13-50.png

Yes, that true.

Anyway I start from the part model.

I've fixed it.
First of all, the problem accoured only when I work with the configuration of Creo that starts linked to WC. If I start the configuration "stand alone" (that "takes" other files) I haven't problems.
It seems that the problem was the presence on WC of the drawing of the start part (template part). Each time I create a new .prt it create also its .drw.
I deleted the start part's drw and now it creates the drw no more.

Announcements