cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Set State on non-latest version is disallowed

Highlighted
Newbie

Set State on non-latest version is disallowed

I have a older version of a CAD Document (Pro/E part) that I would prefer to delete.
However, as we all know, Windchill does not allow deleting of non-latest version.
So, I figured that I would change the state to Obselecense.
I already have an domain policy to disallow access to Obsolete objects.
However, Windchill will not allow me (wcadmin) to set the state.
I get an error that says that that set state is only allowed on the latest version.
What's up with that?


Gerry

7 REPLIES 7
Highlighted

RE: Set State on non-latest version is disallowed

You can configure Windchill to delete the non latest version of the document. You can change the domain policy to such that for wcadmin it should allow to change (change will include everything, i.e, deleting docment, doing set state etc) the object (CAD document). This should slove your problem.

In Reply to Gerry Champoux:



I have a older version of a CAD Document (Pro/E part) that I would prefer to delete.
However, as we all know, Windchill does not allow deleting of non-latest version.
So, I figured that I would change the state to Obselecense.
I already have an domain policy to disallow access to Obsolete objects.
However, Windchill will not allow me (wcadmin) to set the state.
I get an error that says that that set state is only allowed on the latest version.
What's up with that?


Gerry


Highlighted

Set State on non-latest version is disallowed

On 10/18/11 08:49, Sitanshu Prasad wrote:
> You can configure Windchill to delete the non latest version of the document.

How is this accomplished?


> You can change the domain policy to such that for wcadmin it should allow to change (change will include everything, i.e,
> deleting docment, doing set state etc) the object (CAD document). This should slove your problem.
>
> In Reply to Gerry Champoux:
>
> I have a older version of a CAD Document (Pro/E part) that I would prefer to delete.
> However, as we all know, Windchill does not allow deleting of non-latest version.
> So, I figured that I would change the state to Obselecense.
> I already have an domain policy to disallow access to Obsolete objects.
> However, Windchill will not allow me (wcadmin) to set the state.
> I get an error that says that that set state is only allowed on the latest version.
> What's up with that?
>
> Gerry


--
------------------------------------------------------------------------
Randy Jones
Systems Administrator
Great Plains Mfg., Inc.
1525 E North St
PO Box 5060
Salina, KS USA 67401
email: -
Phone: 785-823-3276
Fax: 785-667-2695
------------------------------------------------------------------------
Highlighted

RE: Set State on non-latest version is disallowed

You might want to check the auto purging mechanism in Windchill. It can beaccomplished using the Purge Manager in Windchill.




In Reply to Randy Jones:


Highlighted

RE: Set State on non-latest version is disallowed

Supposedly, wcadmin already has all authority to do anything to any object.
Yet Windchill will not allow wcamin to set-state or delete a non-latest version of a cad document.


Is there a property or preference that must be set?


Gerry.




In Reply to Sitanshu Prasad:



You can configure Windchill to delete the non latest version of the document. You can change the domain policy to such that for wcadmin it should allow to change (change will include everything, i.e, deleting docment, doing set state etc) the object (CAD document). This should slove your problem.

In Reply to Gerry Champoux:



I have a older version of a CAD Document (Pro/E part) that I would prefer to delete.
However, as we all know, Windchill does not allow deleting of non-latest version.
So, I figured that I would change the state to Obselecense.
I already have an domain policy to disallow access to Obsolete objects.
However, Windchill will not allow me (wcadmin) to set the state.
I get an error that says that that set state is only allowed on the latest version.
What's up with that?


Gerry



Highlighted

RE: Set State on non-latest version is disallowed

IIRC, I was told some time ago (and my experience with 9.1 backs this up)the non-latest version cannot be deleted, but the admin accounts (both org and site) can change the state of the non-latest version. I don't know the proper settings to accomplish this, but at least I can confirm the availability.

In Reply to Gerry Champoux:



Supposedly, wcadmin already has all authority to do anything to any object.
Yet Windchill will not allow wcamin to set-state or delete a non-latest version of a cad document.


Is there a property or preference that must be set?


Gerry.



Highlighted

RE: Set State on non-latest version is disallowed

Gerry:


You can use a Promotion Request to Promote a non-latest version to another state. I've had to use this on models that weren't controlled for one reason or another and then had newer modified iterations checked in on top.

Highlighted

RE: Set State on non-latest version is disallowed

That's interesting.
As an admin, I can promote, but not set state?



Gerry

In Reply to Andrew Mansfield:



Gerry:


You can use a Promotion Request to Promote a non-latest version to another state. I've had to use this on models that weren't controlled for one reason or another and then had newer modified iterations checked in on top.


Announcements