cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Stay updated on what is happening on the PTC Community by subscribing to PTC Community Announcements. X

Unique numbering for Number, Name, and File Name for WTParts and EPM Documents

Chris17
11-Garnet

Unique numbering for Number, Name, and File Name for WTParts and EPM Documents

Hello,

 

we have an issue with the numbering of EPM documents and WTparts. The counters for WTParts and EPM Documents are not working in sync. The EPM documents get different numbers from the workgroupmanager, from PDMlink and the WTPart get another number. I even had to add a prefix to the WTPart number to avoid numbering conflicts.

 

This is very confusing for the users. See the screenshot below. Especially when searching for a number in the quick search, the users get several results.

 

Is there a way to keep document numbers in the workgroupmanager, the EPM document and WTpart numbering in Windchill synchronized?

 

The goal is, that the numbers in filename, name and number are identical for the document and the related WTpart.

 

Thanks a lot in advance for your answers.

 

Best

Chris

9 REPLIES 9
BenLoosli
23-Emerald II
(To:Chris17)

Are you using auto-numbering?

You need to write custom code to get all three to be in sync.

There are many documented issues with the way auto-numbering works and wastes numbers.

 

What version and release of Windchill are you on?

 

 

Hi Ben,

 

we are on Windchill 11.0 M030.

 

Yes I use autonumbering. Below is the code in the object initialization XML for WTparts and EPM documents.

Can you give me a reference for instructions on how to keep the numbering in sync?

 

Thank you in advance.

 

Best
Chris

 

<!-- set the number to a generated number -->
<AttrValue id="number" algorithm="com.ptc.windchill.enterprise.revisionControlled.server.impl.NumberGenerator"> 
                  <!-- add a V prefix for variant parts -->
                  <Value algorithm="wt.rule.algorithm.BooleanBranch">
                     <Value algorithm="wt.rule.algorithm.EqualsTest">
                        <Attr id="genericType"/>
                        <Arg>variant</Arg>	
                     </Value>
                     <Arg>V</Arg>
                     <Arg></Arg>
                </Value>
                <!-- the sequence -->
                <Arg>WTP</Arg>
                <Arg>{GEN:wt.enterprise.SequenceGenerator:WTPARTID_seq:10:0}</Arg>
                </AttrValue>
               <!-- set the number to a generated number -->
               <AttrValue id="number" algorithm="com.ptc.windchill.enterprise.revisionControlled.server.impl.NumberGenerator">
				  <Arg>{GEN:wt.enterprise.SequenceGenerator:EPM_seq:10:0}</Arg>
               </AttrValue>
BenLoosli
23-Emerald II
(To:Chris17)

Unfortunately I do not have any references on the code needed. Maybe someone else will have something they can share or point you to.

 

The reason the numbers are different are the Oracle sequence generator uses numbers every time you do anything that calls it. It wastes a lot of numbers when you do a part rename as it grabs a new sequence number for all components even if you do not use them. There are documented cases in the community of this, some claiming up to a 75% wasted numbers due to the non-use of pulled numbers.

I do not use auto-numbering for part or document numbers. I do use them for things that I don't care about the number or are insignificant if there is a number skip.

 

Hi Ben,

 

we noticed too that a lot of numbers are wasted, probably 50% of numbers are unnecessarily skipped.

 

We use an SQL database. I will look for a way to manipulate the number generator.

 

Best

Chris

Chris17
11-Garnet
(To:Chris17)

Hello,

 

using the auto associate functions, I managed to improve the numbering.Key was to disable the WTpart autonumbering. Only then the autoassociate options take effect.

 

One issue persists: when uploading EPM documents the first time, the number is incremented by one. No idea why...I opened another post for this issue.

 

Best

Chris

DmitryC
12-Amethyst
(To:Chris17)

Hi Chris,

 

In your OIR you are using 2 different sequences for WTParts and EPM Documents:

  • WTPARTID_seq
  • EPM_seq

 

To Keep them aligned either use the same OOTB sequence or create a new custom one.

 

Kind regards,

Dmitry.

TomU
23-Emerald IV
(To:Chris17)

According to this post, Windchill 11.0 added this ability:

 

Auto Associate to Create Parts based on CAD Document Number even if OIR for Part is to Generate Number:   Most customers I speak with are a mix of top down and bottom up part creation.  In Windchill 11.0, if your OIRs generate Part number; but it does NOT have an immutable constraint AND the server-side preference, Force Create Autonumbered Parts is set to No, then we shall use the CAD Document's Number instead of generating a new number.

 


 

Chris17
11-Garnet
(To:TomU)

Hi Tom,

thanks for the hint. I checked the settings and the option "Force Autonumbered Part Creation" is already set to "no". Despite this settings we observe the behavior shown in the screenshot in my first post.

It seems to me, that the "name" field is controlled by this option. This is kind of weird: the name field should be a descriptive name and not filled with a number.

Best

Chris

dmcalister-2
13-Aquamarine
(To:Chris17)

I know this is old, but I wanted to add something for anyone running into this problem. The immutable constraint must be removed for number in the wtpart OIR in order for this preference to work.

Top Tags