cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Updating the Model and Loading Reports fails in Windchill 11.0 M030

SOLVED
Highlighted
Garnet

Updating the Model and Loading Reports fails in Windchill 11.0 M030

Hello,

 

I am installing Windchill PDMLink as per Installation and Configuration Guide in a lab environment. There are 3 servers as following installed and configured in the same order. All servers have got no AV, FW disabled, UAC disabled and in same network.

  1. DbSrv: Oracle database and Directory Server components
  2. BusRepSrv: Business Reporting Host components
  3. AppSrv: Windchill 11 M030 Solution and Business Reporting Gateway

 

Installation went smooth. After installation, ran following command for the sake of updating model and loading reports.

  • ant -f D:\ptc\WC11.0\Windchill\installer\wnc\wbr_actions.xml

 

It generated an error as following. Any idea why and how I can fix this?

2018-04-14 21:04:45,385 ERROR [main] wt.method.MethodResultException - Metadata Provider Error
Exception in thread "main" (wt.fc.fcResource/0) wt.util.WTException: The operation: "updateThirdPartyReportModel" failed.
Nested exception is: wt.method.MethodResultException: *ERROR* Server side Exception has occured: See MethodServer log for details
at com.ptc.windchill.cognos.CognosFacade.handleThrowable(CognosFacade.java:3610)
at com.ptc.windchill.cognos.CognosFacade.updateModel(CognosFacade.java:498)

...

...

 

When checked method server log, found below error

2018-04-14 21:04:45,354 ERROR [RMI TCP Connection(36)-192.168.30.62] wt.method.MethodContextMonitor.contexts.rmi wcadmin - 2018-04-14 21:04:26.428 +0400, nzzuoyu;jfzmfzmz;3352;83tmp9;1, -, -, -, wcadmin, 192.168.30.62, com.ptc.windchill.enterprise.report.StandardReportService, updateThirdPartyReportModel, , 0, 10, 0.57966848, 5, 0.01462208, 7.203125, 18.88792576
wt.util.WTException: Metadata Provider Error
Nested exception is: AxisFault
faultCode: Client
faultSubcode:
faultString: Metadata Provider Error
faultActor:
faultNode:
faultDetail:
{http://developer.cognos.com/schemas/bibus/3/}exception:<ns1:severity>Error</ns1:severity><ns1:errorC... Unable to open the model.
</ns1:messageString><ns1:nestingLevel>1</ns1:nestingLevel></ns1:message>

 

Thank you,

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Updating the Model and Loading Reports fails in Windchill 11.0 M030

This issue has been fixed after few trial and errors.

 

It is found that only FixPack 2 should be applied to Cognos 10.2.2 though FixPack is available from IBM site. The whole thing was that even PTC support technicians confirmed to install FP10 and gave wrong configuration. After installation of FP2 without changing any further property values, I could update the model and load reports successfully.

1 REPLY 1

Re: Updating the Model and Loading Reports fails in Windchill 11.0 M030

This issue has been fixed after few trial and errors.

 

It is found that only FixPack 2 should be applied to Cognos 10.2.2 though FixPack is available from IBM site. The whole thing was that even PTC support technicians confirmed to install FP10 and gave wrong configuration. After installation of FP2 without changing any further property values, I could update the model and load reports successfully.