cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading from 9.1 to 10.1 - Client configuration

cc-2
5-Regular Member

Upgrading from 9.1 to 10.1 - Client configuration

Hello



In the past we have experienced some conflicts with different versions of ProductView or Windchill Desktop Integration between our production server and test server at different built.



I am expecting that this will be the case here again. Our production server is 9.1 M050 and we are planning to upgrade to 10.1


The implementation team will need working on both servers (the current production server and a test server on 10.1)



I am currently wondering if the implementation should have a additional laptop or workstation to be used only with 10.1 or have on their current computer a virtual environment installed to be used with 10.1 only.



Fortunately we are not upgrade ProE to Creo at the same time so we do not have to deal with that as well. However, there are enough potential issue with PDMLink, I mentioned ProductView and WDI but there is also the possibility to use newer version of Java, Internet Explorer etc.... which do not cohabit well together on the same windows session.



How do you handle such situation ? Addition computer ? virtual environment ? something else ?



Thanks


Best regards

2 REPLIES 2
rkalbhor
1-Newbie
(To:cc-2)

Hi Mott,

Ususally when it comes to testing the post upgrade(test phase) Windchill I
would recommed to dedicate atleast one machine which is exactly identical
to the machine that will be used by the endusers. It might not give the
best of performance sinche the server will be on a test environment. But
you will be able to figure out other issues such as compatibility, IT and
JRE issues.
Regards,
Rohan


Rohan Kalbhor
Email:- | Mob: +91 9011759898

Hi,

We did the following during our testing of 10.1 from 9.1 M060:
- made sure our clients stayed on Java 1.6
- upgraded ProductView clients to Creo View 2.0 before the upgrade. Then you have less stuff to handle concurrently. I can't remember if I did something to disable the ProductView version checker on our 9.1 server. test it out on a single client.
- you are right DTI is neither backwards nor forward compatible but needs to match the Windchill server. Disabling it in either the old or new through preferences is the only way to handle it. There are other ways to upload/download files. In addition you can use install/uninstall to switch back and forth on DTI versions within a few minutes.

Jørn
Announcements