cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Upload cache folder related error

aakolkar
4-Participant

Upload cache folder related error

Hi Fellow Windchill+CAD users,

Have created a new product (as per our business processes) and workspace for it and also have created and configured vaults and vaulting rules for it (Details attached)

For upload of a new ProEngineer CAD part (without any geometry) on a client machine getting the following error: "A problem on the server prevented upload. Please contact your system administrator."

Attempted the same thing on the Windchill server(which has ProE) and getting the following error: "Upload of Pro/Engineer model files failed. Please check the designated upload cache folder is correctly configured."

Attached is a pdf document for the steps taken to debug this issue both on the client and server end including vaulting configurations. Out of your experience- please let me know what needs to be changed/configured.

Thanks in advance!

Windchill8.0M030+Wildfire 3

~Amol

Alicon/Atlas Castalloys(Silicon Meadows Design Ltd)

1 ACCEPTED SOLUTION

Accepted Solutions
aakolkar
4-Participant
(To:aakolkar)

Fellow Windchillers!!

This solution is also for: New Windchill Document creation error

The above errors are solved by removing "unreferenced files" for the "defaultcachevault" using the product>utilities>ext. storage administration>Vault config.UI

Remove_unref_UI.png

The above actions prompt you with a warning message as follows (which is remarkable!!! ) after clicking ok on this message the "unreferenced files" were removed from vault and the above errors ceased.

UnRefRemove_1.PNG

OTHER WAY: if the drive is full for the folder mounted for the "defaultcachevault" then change/update the mounting for the folder of the "defaultcachevault" to the new location.

DefCache_Mount.PNG

Thank you for the valuable inputs!!

~Amol

View solution in original post

3 REPLIES 3
BenLoosli
22-Sapphire III
(To:aakolkar)

Make sure the DefaultUpoadVault on your Windchill server is enabled for RW. This folder is under your loadpoint for Windchill, not on your vault drive(s).

My Windchill loadpoint is E:\ptc\wc_10|Windchill and the path to the DefaultUpoadVault is E:\ptc\wc_10|Windchill\vaults\DefaultUpoadVault.

aakolkar
4-Participant
(To:BenLoosli)

Ben-  Thank you for the reply!!

Did check that the DefaultUpoadVault on the Windchill server and it is Read-Write!

The following things catch my attention:

  •     There is no error/trace related to the Event Manager errors in the MethodServer log (attached please find it in the in the zip format)
  •     There are 2 different error messages on different machines/clients and there is no trace of it in the MServer log. 

Any clues?

Kind Regards,

Amol

aakolkar
4-Participant
(To:aakolkar)

Fellow Windchillers!!

This solution is also for: New Windchill Document creation error

The above errors are solved by removing "unreferenced files" for the "defaultcachevault" using the product>utilities>ext. storage administration>Vault config.UI

Remove_unref_UI.png

The above actions prompt you with a warning message as follows (which is remarkable!!! ) after clicking ok on this message the "unreferenced files" were removed from vault and the above errors ceased.

UnRefRemove_1.PNG

OTHER WAY: if the drive is full for the folder mounted for the "defaultcachevault" then change/update the mounting for the folder of the "defaultcachevault" to the new location.

DefCache_Mount.PNG

Thank you for the valuable inputs!!

~Amol

Announcements