cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

WGM Workspace Location

SOLVED
Level 8

WGM Workspace Location

Hello there,

 

I am having issues with setting the cache and workspace location in the workgroup manager.

 

I set the environmentvariables as follows:

 

PTC_WF_CACHE = %LOCALAPPDATA%\Windchill\cache

PTC_WF_ROOT = %LOCALAPPDATA%\Windchill

PTC_WFS_ROOT = %LOCALAPPDATA%\Windchill\.wgm

PTC_WGM_ROOT = %APPDATA%\PTC\Windchill Workgroup Manager

PTC_WGM_STARTUP_DIR = %LOCALAPPDATA\Windchill

PTC_WLD_ROOT = %LOCALAPPDATA%\Windchill

 

The cache location is correctly set to the path in the environmentvariables.

 

However, the Windchill file system management sets the storage location for the workspace to %USERPROFILE%\Documents\PTC Environment.

 

When trying to save files to the Workspace using Solidworks, Solidworks tries to save to %USERPROFILE%\Documents\PTC Environment and fails.

 

Using the standard path in %USERPROFILE% is not possible. This folder is on a server. Using a simple path like C:\PTC\Windchill is not possible as we have several computers that are shared by several users.

 

Thank you in advance for any hints how to solve this issue.

 

Best regards

Chris

 

 

 

 

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: WGM Workspace Location

Hi Chris,

 

the WFS doesn't work the same way as the WGM for Creo does.

Hence, you need to use the bellow command:

set WWGM_VFS_PTC_PLACES=<locationOfYouChoice>
<WGMDIR>\i486_nt\obj\wwgmvfsconfig.exe"

Florent

Florent ROUSSEL
www.4cad.ca
3 REPLIES 3

Re: WGM Workspace Location

Hi Chris,

 

the WFS doesn't work the same way as the WGM for Creo does.

Hence, you need to use the bellow command:

set WWGM_VFS_PTC_PLACES=<locationOfYouChoice>
<WGMDIR>\i486_nt\obj\wwgmvfsconfig.exe"

Florent

Florent ROUSSEL
www.4cad.ca

Re: WGM Workspace Location

Works perfectly! Thanks a lot, Florent!

 

For those who'd like to reproduce:

 

Create folders:

%LOCALAPPDATA%\Windchill
%LOCALAPPDATA%\Windchill\Workspace

set environment variables:

 

PTC_WF_ROOT = %LOCALAPPDATA%\Windchill
PTC_WFS_ROOT = %LOCALAPPDATA%\Windchill\.wgm
PTC_WGM_ROOT = %APPDATA%\PTC\Windchill Workgroup Manager
PTC_WGM_STARTUP_DIR = %LOCALAPPDATA\Windchill
PTC_WLD_ROOT = %LOCALAPPDATA%\Windchill

 

 

execute two commands in terminal as user:

set WWGM_VFS_PTC_PLACES=%LOCALAPPDATA%\Windchill\Workspace
"C:\Program Files\PTC\wgm\i486_nt\obj\wwgmvfsconfig.exe"

 

start workgroupmanager, register server and check cache and wfs location.

Re: WGM Workspace Location

In Windchill 11.1 M020, the Windchill Workgroup Manager installer reads "PTC_WFS_DEFAULT_LOCATION" to define the Windchill folder location to a local folder for WFS. I recommend to use this newly supported Windows system variable because setting WFS folder is one time thing, it does not have to be repeated every time WWGM is launched.

 

After installation, you can define the Windchill Folder path from the WFS management UI by 'Tools > Windchill File System Management'.