cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Windchill 10.x global search

Moonstone

Windchill 10.x global search

We just upgraded this weekend to 10.1 M040. All working pretty well except one major problem.



Executing aSearch usingthe Search field in the upper right (global search) returns either no data or bizarre results, usually with no CAD doc's returned but occasionally not returning WTRefDoc's either. Have had hours and hours of web sessions on this. Not repeatable. Have changed / reset related preferences many times. Have done multiple test upgrades on different servers - randomly seem to get this behavior.



We have SOLR indexing installed but have not done indexing and indexing new is not enabled. But - Setting the preferenceindex search = yes (sometimes only) fixes the problem. This should not be related so maybe it's just a ghost in there.




Urgent request: Until this is figured out we'd like to simply remove the Search field in the upper right and the related Types drop-down immediately to the left of it until this is figured out. That will force users to access Advanced Search via the navigator only. We're very familiar with using ActionModels to control this type of thing - but it seems that Search is not defined via ActionModels - must be some other method. PTC is working on how to do this via tech support case also.



For now we're handling by emailing all users with the instruction not to use global search.



///


This seems incredible to us - how can Search not work!!! Has anyone else seen this in 10.x?



thanks in advance

4 REPLIES 4

Windchill 10.x global search

Hi Mike

We have had all sorts of issues with Search since moving from 9.1 to 10.0. We went to 10.0 M030 initially and found issues with the way wildcards behaved, leading wildcard in particular. We got our heads around that and then found other issues in the rendering of the search results, in that more results were being returned than were actually being rendered. Perhaps a similar issue for you?

The behaviour of the leading wildcard change between 10.0 M030 and M040 but still leads to some results that appear inconsistent to end users that are not familiar with its varied behaviour. Discussions with PTC have led to a technical issue with wildcards and Solr in particular which have not been seen in the past with RetrievalWare or InStream that is still being worked on.

Paul

Windchill 10.x global search

Guys,

We have issue with searching for groups too.

Entering a wildcard at the beginning or end of a search string works fine
but entering it inside the search string returns nothing.

For example
*Engineers returns lots of groups
M*Engineers return nothing even though we have groups that meet that
search criteria.

Windchill 10.1 M010

David Graham
Windchill Developer/Administrator
CAx Administrator


Emhart Glass Manufacturing Inc.
Emhart Glass Research Center
123 Great Pond Drive | Windsor, CT 06095 | USA
Telephone +1 (203) 376-3144 | Telefax +1 (860) 298 7397
Mobile +1 (203) 376-3144 |

Windchill 10.x global search

We saw this too, I think in 10.0 as well as 10.1. I had entered a case and supposedly there was already an SPR on it. Tech support did confirm that wildcards in the middle of any participant searches did not work.

Windchill 10.x global search

Update...


* We applied the patch to Oracle to our validation and production systems (see attached Word doc on this if interested) and this solved the problem of CAD Doc's not being returned from Global Search unless a leading * was used. We have hidden global search in our 10.1 production system since the 2nd day going live because of this problem, but will re-enable tomorrow.


* We're now struggling with deciding to enable full text indexing or not. Probably will not do so. With indexing in place, users get a host of unwanted and confusing results via "global search." Our strong preference would be to have the system configured in reverse of how PTC has provided it:

o Search on Number and/or Name (not mixed) via Simple Search

o Search on keyword only if the user explicitly selects to do so
Announcements
LiveWorx Call For Papers Happening Now!