cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Worker Agent does not start

SOLVED
Highlighted
Newbie

Worker Agent does not start

Hello All,

I'm trying to setup my worker to work with Solidworks. I get the following error in the logs:

[2017-02-07 11:35:28] workermonitor - Version : Creo 3.1 - M010 (13.3.10.27) i486_nt

[2017-02-07 11:35:28] Logging level set to 0x01.

[2017-02-07 11:35:28] Connecting to server "XYZ.com" on port 5600

[2017-02-07 11:35:28] Connection established

[2017-02-07 11:35:28] Got version 8 INIT  FAILURE (with no description) from WVS.

[2017-02-07 11:35:28] Monitor Shutting down.

The worker does NOT indicate "Fails to start" in the Worker Agent Administration page, it just stays off.

In sw2pv_config.exe, I have

- the setup directory pointing to the folder sw_setup

- Server Host & Server Port 5600: Failing the test, I get this message

Set keepalive ok

The CADAgent rejected the connection, is it configured for a SOLIDWORKS worker on machine WIN-9U6A5RRLNG0 (alias not set)?

What I've tried so far:

- Checked that the host name and port 5600 are correct

- Checked that the system does not run out of memory

- Checked for other forums with the same issue

Please help,

Ammar

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Worker Agent does not start

I think this is a problem with the hostname. The host name which your worker claims is not same as the hostname which you have in your agent.ini file.

Are you using a alternate hostname or shortname? If you are not using a shortname(just the hostname), try using shortname in your agent.ini.

On a sidenote, the localfilepath is incorrect, and this is not the reason of the error though- localpath=ftp:.

View solution in original post

11 REPLIES 11

Re: Worker Agent does not start

Hi Ammar,

After setting up worker directory on CAD worker, you will also need to configure CAD worker agent from CAD worker administration. If you already did this, then please hare you agent.ini file.

Also check if you have following property set in wvs.properties

<Property name="worker.exe.whitelist.prefixes" overridable="true"

             targetFile="codebase/WEB-INF/conf/wvs.properties"

             value="C:\|D:\|G:\|/|nohup /"/>

Re: Worker Agent does not start

Thanks a lot for the reply Dipak.

My trusted prefixes are set correctly. Here is the content of agent.ini:

[agent]

transferpath=$(wt.temp)\transfer

port=5600

numworkers=1

;

[worker1]

localpath=ftp:

maxinstances=1

username=

prompt=

starttime=80

host=XYZ.com

password=

autostart=false

autoidlestop=

startfromlocal=FALSE

exe=D:\ptc\creo_view_adapters\sw_setup\swworker.bat

remotepath=

hosttype=local

port=601

distributed=false

autoerrorstop=false

availabletime=

shapetype=SOLIDWORKS

autobusystop=

;


Ammar

Re: Worker Agent does not start

Re: Worker Agent does not start

Not the same issue as what I'm having. My worker isn't failing to start it's just staying off. My host name is correct.

Any other idea?

Re: Worker Agent does not start

The property "worker.exe.whitelist.prefixes" is case sensitive

<Property name="worker.exe.whitelist.prefixes" overridable="true"

             targetFile="codebase/WEB-INF/conf/wvs.properties"

             value="d:\|D:\"/>

Re: Worker Agent does not start

Thank you Sergey but unfortunately the issue is not originating from the prefixes, I have them already setup correctly.

Can you think of another solution?

Re: Worker Agent does not start

Hi Ammar,

Could you please share worker logs as well as CADAgents logs along with a screenshot of CAD worker?

Dipak

Re: Worker Agent does not start

The SolidWorks starts?

Re: Worker Agent does not start

I think this is a problem with the hostname. The host name which your worker claims is not same as the hostname which you have in your agent.ini file.

Are you using a alternate hostname or shortname? If you are not using a shortname(just the hostname), try using shortname in your agent.ini.

On a sidenote, the localfilepath is incorrect, and this is not the reason of the error though- localpath=ftp:.

View solution in original post