cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

fix library parts associations

Highlighted
Amethyst

fix library parts associations

Hi All!


I have some messed up library parts associations.


Hundreds of instances were revised without wt.parts resulting in latest cad doc not having association to any wt.parts. Fixing it is very tydious process that has to be done on each cad doc and require disassociate and associate steps.


Does anybody have a better solution? PTC said to file customization request...



Thank you


D

1 REPLY 1

RE: fix library parts associations


Dimitry,
I have seen this problem before. Here is how my tech team resolved it after I wrote up our requirements. In our case we were attaching a PDF with a reference link; but the concepts here should apply. BTW, we did this in 9.1, haven't had to move it to v10.x.



In a product folder or library with appropriately locked down permissions:


1 - Create a new lifecycle with an obvious name like CAD_DOC_ASSOC_2_WTPART. Make sure this lifecycle template is applied to any state that all the parts might be in.


2 - The lifecycle is start - robot - end and the robot is simply code that creates the described by link.


3 - the code is a helper class loaded on the server in the appropriate location that links together the appropriate objects based on your parameters. In our case we had the same number for the PDF object and the WTPART.


4 - To use this "tool" do the following;


B - Select all and choose reassign lifecycle.


D - Choose OK and wait. Takes a while but should do the trick.



Please PM if you need more info.



Scott Claes


info@claes.biz


www.claes.biz


Bringing ECAD to PLM