cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need help navigating or using the PTC Community? Contact the community team. X

no generated steps under representation

Mat
13-Aquamarine
13-Aquamarine

no generated steps under representation

Hi there,

 

I recently switched from Windchill Essentials to PDMLink.

In Windchill Essentials the worker created several export formats according to the EPM-doc-type (pdf for drawings, step for cad-parts, etc.).

Though I did not changed "Creo View Configuration for Site"

(under Site->Utilities->Visualization Configuration Administration ), additional files under "representations" are no longer created.

e.g.
a cad-part, which was released and published under Windchill Essentials, shows an available step-download

Mat_0-1665753219235.png

 

a cad-part, which was released under PDMLink, shows no step-file

Mat_2-1665753442785.png

 

where to start?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
HelesicPetr
21-Topaz II
(To:Mat)

Hi @Mat 

 

Have you set a xconfmanager preference to use publish rules? 

 

It seems that the Publish rules are not used because the Description of the visualization do not contains the Publish rule description. 

 

Check the 

xconfmanager -s publish.usesPublishRules="ARBORTEXT MPMLINK GALAXY PROE" -t codebase\WEB-INF\conf\wvs.properties -p

 

description in article CS81396

 

PetrH

 

View solution in original post

5 REPLIES 5
MikeLockwood
22-Sapphire I
(To:Mat)

This article, along with Publish Rules, is a good place to start.

CS216668

 

Mat
13-Aquamarine
13-Aquamarine
(To:MikeLockwood)

Thanks for CS216668.

But unfortunately, this article does not give me any clue, what is wrong with my configuration.

 

I attached my active PublishRules, which worked until my upgrade from Windchill Essentials to Windchill PDM Link.

Maybe there is an error, that I do not see.

 

 

 

 

 

HelesicPetr
21-Topaz II
(To:Mat)

Hi @Mat 

 

Have you set a xconfmanager preference to use publish rules? 

 

It seems that the Publish rules are not used because the Description of the visualization do not contains the Publish rule description. 

 

Check the 

xconfmanager -s publish.usesPublishRules="ARBORTEXT MPMLINK GALAXY PROE" -t codebase\WEB-INF\conf\wvs.properties -p

 

description in article CS81396

 

PetrH

 

Mat
13-Aquamarine
13-Aquamarine
(To:HelesicPetr)

Thanks,

indeed "xconfmanager -d publish.usesPublishRules" gives back

 

Property information for 'publish.usesPublishRules':
   Multivalued property delimiter:
   Values:
   - ARBORTEXT

 

So, the "PROE" part is missing.

I changed the config and will give it a try.

 

Update:

it works!

Mat_0-1666255560720.png

 

 

TR_10449171
4-Participant
(To:Mat)

This article is very nice place to start. Thanks for this article. 

Top Tags