cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

"Registering Server" during visualization process takes a long time.

SOLVED
Visitor

"Registering Server" during visualization process takes a long time.

I've set up a CADworker with Creo 3 M100 and creo view 3.1 on a windows 2008 R2 VM. I setup 2 workers on this server. The CADworker works as expected for the most part, the only issue I have is that it takes 2 minutes to register the server. Regardless of whether or not the worker agent is started the bottle neck of the process is the 2 minute wait while registering the server. Is there some optimization I'm not performing? Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: "Registering Server" during visualization process takes a long time.

Hello Andrew,

This issue might occur if Publisher user have lot of publish#####tmp workspaces.

To optimize the performance, Regularly delete the residual publish#####tmp workspaces from the My Workspaces view for the Windchill administrative account configured in the auth.properties file

7 REPLIES 7

Re: "Registering Server" during visualization process takes a long time.

If you run multiple workers on the same host, you need to separate the environment

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS29308

Multiple CAD Workers

Highlighted

Re: "Registering Server" during visualization process takes a long time.

I have this set on my CADworker and I have random times where it takes exactly 3 minutes to register the server.  It doesn't happen with every job, and it cannot be duplicated by trying the same object.  It is completely random. I too am on a virtual 2008 server but am using Creo 3.0 adapters with Creo 3 M100 in Windchill 10.2 m030 CPS09.

Re: "Registering Server" during visualization process takes a long time.

Try to update Creo 3 to M110 or M120. We had different problems with the M090 and M100...

Re: "Registering Server" during visualization process takes a long time.

Hello Andrew,

This issue might occur if Publisher user have lot of publish#####tmp workspaces.

To optimize the performance, Regularly delete the residual publish#####tmp workspaces from the My Workspaces view for the Windchill administrative account configured in the auth.properties file

Re: "Registering Server" during visualization process takes a long time.

Here is what I tried so far.

I reviewed CS29308 and the only difference I can find between that article and what I have is the command in the proeworker.bat.

CS29308 has:

"<Adapters>\i486_nt\obj\workermonitor" -UH -s "<Adapters>\i486_nt\obj\proe2pv" -DA proeworker_1 -vt -r proe2pv.rcp -EW PROE -CS<server> <port> %*

My command has a call to proe_startup.bat:

"<Adapters>\i486_nt\obj\workermonitor" -su "<Adapters>\proe_setup1\proestartup.bat" -UH -s "<Adapters>\i486_nt\obj\proe2pv" -DA proeworker_1 -vt -r proe2pv.rcp -EW PROE -CS<server> <port> %*


I updated my call to match the format of the one in CS29308. Publisher still works, but no change in the Registering Server time (still 2 minutes on all jobs). I'll try the deletion of temp work spaces next.

Re: "Registering Server" during visualization process takes a long time.

Removing those temp workspaces did the trick. We had never deleted these workspaces and there were over 6000 in the system. After deleting the tmp workspaces the "Register Server" step now takes from 1 - 10 seconds. Quite a time savings, Thanks.

Re: "Registering Server" during visualization process takes a long time.

Glad to know that.

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum! ______________________________ Check out the Windchill Tips Board! We're talking about Whirlpool's use of digital twin, augmented reality, and data-driven design!

The NAVIGATE WORKING GROUP is here! Come innovate with PTC!

Sign up for a Working Group