Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Your Friends List is a way to easily have access to the community members that you interact with the most! X

Error Installing Personal Edition


Error Installing Personal Edition

I am having trouble installing Creo Elements Direct PE on Windows 7 - 64 bit. The installer quits with: "Internal Error 2738". Others have suggested that I can fix this problem by running regsvr32 c:\windows\syswow64\vbscript.dll. Unfortunately, this did not help on my system.

Does anyone have other suggestions?

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

After countless hours of not finding the solution to this problem, I got Creo Elements to install on my Windows 7 64 bit machine. I tried the solutions offered by every single page mentioning the dreaded "Error 2738" and nothing worked. Until now.

The install log created by the downloadable EXE is not helpfull at all (probably because the MSI is not being run directly), so the first thing I did was look for the uncompressed files (search for osdm.msi). Ran the MSI using msiexec with full logging, and found that, lo and behold, there was an error with vbscript:

"MSI (c) (68:40) [21:28:47:788]: Doing action: ExportProperties

Action 21:28:47: ExportProperties.

Action start 21:28:47: ExportProperties.

MSI (c) (68:40) [21:28:47:789]: Creating MSIHANDLE (12) of type 790542 for thread 6208

MSI (c) (68:94) [21:28:47:823]: Creating MSIHANDLE (13) of type 0 for thread 660

DEBUG: Error 2738: Could not access VBScript runtime for custom action

Info 2898.For Tahoma8 textstyle, the system created a 'Tahoma' font, in 0 character set, of 13 pixels height.

DEBUG: Error 2835: The control ErrorIcon was not found on dialog SetupError

Internal Error 2835. ErrorIcon, SetupError

Internal Error 2738.

MSI (c) (68:94) [21:28:51:925]: Product: Creo Elements/Direct Modeling Express 4.0 ( x64 ) -- Internal Error 2738"

While every single post says to re-register vbscript.dll (always returned "successful") and/or deleting the registry entry for vbscript under HK_current_user (didn't exist in my case), the verbose log gave me something else to look for. Googled "Could not access VBScript runtime for custom action", and after some time found what solved the problem...

-Drums, please-

The solution came from here: (along with )

The actual problem is that, despite the registry entry being in the right place (HKLM), it points to the wrong directory. The entry under "InprocServer32" must point to "C:\Windows\system32\VBScript.dll", but was pointing to "C:\Windows\syswow64\VBScript.dll" instead. I have no idea why this happened, but it looks like McCaffee (which came as a demo on my machine) had something to do.

So, the solution seems to be: try what everybody suggests (re-register the DLL, etc) and if/when everything else fails go to the registry and make sure the InprocServer32 points to the right folder. If not, change it (you'll need to play with the permissions), and voila...

PD: Excuse my "brevity"

This posting was helpful and I really thought would solve my problem, but unfortunately it did not.

I too am getting the "Internal Error 2738" when trying to install "Creo-Elements-Direct-Modeling-Express4-M010-64-setup-EN" on my Vista Ultimate 64 bit machine.

So far I've tried both the solution above and the simple command prompt solution to re-register vbscript.dll.

I've rebooted the machine after each fix, and each time I still get the same error.

I've done several searches on line, but I've not found any new information, all keep pointing to fixing the path for the vbscript.dll with regedit or re-registering it. (There is also some sort of program running around that fixes vbscript issues, but I've downloaded this application and it does not run on my Vista 64 bit machine.)

Any other suggestions?

Top Tags