Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Outdated sketcher references


Outdated sketcher references

All -

I have a user working on a complicated plastic part that was created using
ISDX for the initial surfacing. About once a day he'll run into a feature
failure that, when he goes in to the sketcher to redefine, will list some
outdated references. The problem is ProE will not let you update or delete
these outdated references, nor can you delete even the good references.
Since it won't let you out of the reference dialog box without resolving
these outdated references, the user is forced to exit out of ProE
completely. I tried cancelling out of the sketch (nope), turning off intent
manager (negative), deleting the references on the part itself (no way), and
probably a few other things that I have forgotten about. Has anyone seen
this before? And if so, is there a solution or is the feature corrupt and
need to be rebuilt?


Same problem now, although it's editing a simple extrude feature that has a mirror as a child in a normal solid. 


Having a mirror as a child means it won't let me add/delete refs but I can't quit anything with the 'outdated references' box open. 

You should be able to cancel the Sketch tab to get out of it.  It works for me in 4.0 M130.


You can then try edit references to replace the failed reference.  You may have to replace the mirror feature.


There is always more to learn in Creo.

I've just built a test model to try this again this morning & I can close the sketcher with the big red X in the ribbon on that model. 

I was working on a production model when I saw this issue yesterday, I'm convinced it wouldn't let me quit but I don't have the model in that state anymore to verify that. The references dialog box does appear on top of the green tick/red X though so maybe I tried everything in sight other than that!, now I'm doubting myself! 


Yesterday I ended up using resorting to File > Exit so I got the save ribbon thing at the top & managed to save all of the other models in session and only lose the one I was working on