Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Want the oppurtunity to discuss enhancements to PTC products? Join a working group! X

Replace unrelated component- stopped working with M110?


Replace unrelated component- stopped working with M110?

Afternoon all,
Hoping somebody can shed some light...

I'm running WF4 and have recently upgraded to M110 from M050. With M050 if I selected to replace an assembly component with an unrelated component, I could select the "Edit Ref Table" button and define the replacement assembly features. When I attempt the same thing now, selecting the "Edit Ref Table" button doesn't work... I get a message in the notification area that indicates "Option Pro/ASSEMBLY not ordered, please contact your sales representative".

Has anybody else seen this same behavior with M110? I have also recently received new license codes due to moving the FlexLM server... there were no other license changes, so I can't see how this might have caused this issue.

Thanks in advance for your help.


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

I think I saw somewhere that this was now on Advanced Assembly Extension (AAX) but I thought that it was for Wildfire 5.0 not Wildfire 4.0.

It sounds like your Pro/E startup command is not grabbing the AAX extension. There is a step in the setup that is easy to miss where you have to associate extensions with the foundation license.

Thanks António and David for your replies.

I don't have AAX, which I believe used to be required for this functionality (via an interchange assembly). As I recall, starting with WF4, this functionality was included with Foundation, and worked perfectly with the builds up to M050 (64bit). I haven't tried any builds between M050 and M110, but it definitely isn't working with M110 (64bit). Interestingly, I received a reply to this posting from another user who reported that this functionality <u>is</u> working with 32 bit M110.


Ewan and all,

You are experiencing the resolution of a very unfortunate licensing bug that snuck into WF 4.0.

Unrelated replace is essentially interchange assembly on the fly (without the actual interchange assembly) and in the pairing table you can actually also create an interchange assembly if you wish.

Because of its similarity and tight connection with interchange assemblies it was never intended to be part of the foundation package.

It was in fact announced as an AAX enhancement from the start.

Please see the WF 4.0 AAX online release notes:

I'm very sorry for the inconvenience this has caused.

Vincent Pihlstrom

Product Manager Pro/E Assembly.

Vincent, Ewan and all,
Here's a work around that gives you some of the replace unrelated functionality. This is something I don't think many of user realize they can use. I use it all the time.

First off you need the config option:
obsolete_pre_wf3_layout_replace yes

when you pick Replace, select the Layout radio button in the dialog box and then browse for the part or assy to replace.

If your parts are at all similar then when you pick OK, ProE will look for the same feature references in the new part and assume they still apply. If all the references exist then the objects will be fully constrained as in Wildfire 2 and previously. If only some of the references exist the part will be partially constrained.

Where this works well is where the new and old parts are very similar. For example, say you made a copy of the old part and made changes to it and now want to replace the old part with the modified part. In that case, it highly likely that the surface feature numbers of the two parts are the same. Thus ProE will see that and the part will be either fully constrained or partially constrained. Another example is say you built a pan head screw family table by starting with a copy of a round head screw generic. As long as you don't disturb the insert cylinder and the mounting surface in the sketcher, then those surfaces will have the same feature numbers and you will be able to use replace by layout to switch one type of fastener with another.

What doesn't work.
All the downstream assembly references get hosed so you have to go back and redefine them. If you do this a lot, you might want the config option: freeze_failed_assy_comp yes Of course then you will want to show the status column in the model tree so you know what's failed and what hasn't. Typically I only have to redifine one or two parts before everything in the model tree is ok.

David Haigh
Phone: 925-424-3931
Fax: 925-423-7496
Lawrence Livermore National Lab
7000 East Ave, L-362
Livermore, CA 94550

Yes,while it is unfortunate that this config has been made publicly known, that is true.

But everyone should know that this is a hidden config and the use of it is unsupported.

The old pre WF 3.0 behavior (which is turned back on with this config) is unstable and caused many SPR's to be reported.

That's why it was changed in WF 4.0.....

Essentially what it allows you to do is to use layouts without declaring references.

It simply picks up the same feature ID's. So if you models always are modeled the same way (or you are replacing with a copy) a c-system, three planes etc etc, it works.

But if the same ID represents very different features in your models it may not work.

I would highly recommend against using that config.

You should really consider getting AAX if you are doing a lot of replacements.


21-Topaz II


I will respectfully disagree. Even if Pro|E cannot find the references in the new model, or if it comes up with entirely wrong references, at the very least you are left with your constraints in place so all you need to do is specify new component refs. That alone is worth using 'by layout'.

Most of my work is still on WF2 these days and I use the replace 'by layout' command all the time and love it, even when it fails.

Doug Schaefer
Doug Schaefer | Experienced Mechanical Design Engineer

I'll have to respectfully disagree with you on this.

I've been using replace by layout for years and never had a problem I would consider an SPR. (since WF1)

Yes if the parts are not totally similar the results may not be what I want, but because I understand how it's figuring out what references to use, it doesn't bother me when a part doesn't assemble exactly as I would have liked. I just delete the bad references and create new ones.

Using replace by layout saves me a lot of time. I will typically try it first before trying unrelated replace. it's just so much quicker for most of the work I do.


Hi Vincent,

Thanks for jumping-in and clarifying this issue… appreciated.

I’ve rolled back to WF4 M050 so I can take advantage of the “bug” for now. I gather when we move to WF5 I’ll need to take a closer look at AAX.



Thanks David for posting this workaround... albeit an officially unsanctioned one 😉


Top Tags