cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Arbortext Editor 6.1 randomly adds unwanted newlines, aka carriage returns, througout the text

GregoryMackenzi
1-Newbie

Arbortext Editor 6.1 randomly adds unwanted newlines, aka carriage returns, througout the text

Arbortext Editor 6.1 adds unwanted newlines aka Carriage Returns througout the text. They are not visible within the editor but are visible in any text editor. This is an extremely annoying behaviour. Is there any way to turn this "feature" off. For anyone that runs scripts over the markup this is a pain because this breaks search patterns.

Example: The newlines break at odd places, for example there's a cr after <xref:

in accordance with sub-paragraph <xref

linkend="myid"></xref>.

1 ACCEPTED SOLUTION

Accepted Solutions

Ok per your suggestion if the outputrecordlength is set to infinity all newlines are removed from the xml file. If you already have a file full of newlines, setting this and then re-opening and saving the file will remove all of the unwanted newlines aka carriage returns.

In the Editor:

Tools/Preferences

Click on the dialog's Advanced... button

scroll down the list to outputrecordlength

select it, click on the edit button

set it to infinity, it is 72 by default in my installation of the editor

Close

OK

.

View solution in original post

9 REPLIES 9

In Arbortext Editor there is writenobreakattag variable.

Set this to a value of "on".

In Arbortext Editor one can set the outputrecordlength.

This may help also.

See Arbortext Editor's Help Center for further details.

Thank you Tim, I'll give that a try, hopefully that will cure the problem.

In the meantime I also wrote a little Omnimark script to remove the unwanted returns:

;omnimark -sb om_newline_cleaner.om input.txt -of output.txt -log error.txt

cross-translate

;PURPOSE

;The purpose of this script is to remove newlines from PTC Arbortext 6.1 text.

;Script Author Greg MacKenzie

find (">" white-space* "<") => ThrowAway; finds newlines, tabs, and other spaces between tags
output "><" ;removes newlines from in between tag brackets

find "%n" => ThrowAway; all remaining newlines should be in the middle of text or markup, bears checking though
output " " ;adds a space where the newline was

Per your suggestion:

In the Editor:

Tools/Preferences

Click on the dialog's Advanced... button

scroll down the list to writenobreakattag

select it, click on the edit button

set it to on, it is off by default in my installation of the editor

Close

OK

I closed the editor and doubleclicked on an xml file.to open it and relaunch Arbortext Editor 6.1.

Changing this setting made no difference whatsoever. It took a file I had removed all newlines from and added them as before, including in unwanted places. I'll try the other suggestion.

The help center does not contain any entries for either writenobreakattag or outputrecordlength if you attempt to search for them using the search feature. When you enter these into the search dialog box they do not turn up. When one types preference, and looks for Advanced, set command options, the result is pretty obtuse, I don't see any entries for either.

Writenobreakattag.png

I hope the screenshot sent is helpful for finding the documentation in the Arbortext Help Center.

You should be able to get to the Help Center by select the menu pick Help > Help Center.

Hi Tim,

I did exactly that previously, and I got no result at all.

writenobreakattag.JPG

Ok per your suggestion if the outputrecordlength is set to infinity all newlines are removed from the xml file. If you already have a file full of newlines, setting this and then re-opening and saving the file will remove all of the unwanted newlines aka carriage returns.

In the Editor:

Tools/Preferences

Click on the dialog's Advanced... button

scroll down the list to outputrecordlength

select it, click on the edit button

set it to infinity, it is 72 by default in my installation of the editor

Close

OK

.

Thanks Tim!

Announcements