cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can Bookmark boards, posts or articles that you'd like to access again easily! X

Editor 5.4 spell-check problems

ptc-953926
1-Newbie

Editor 5.4 spell-check problems

Adepters,

We're planning to move to Editor 5.4 and during preliminary testing I've noticed some very strange behavior with spell-check when compared to Editor 5.2.

First, it's taking words from one or more adjacent tags, merging them, and highlighting them as a misspelling. Unfortunately, these words would never appear together. For example, our index tagging: <indexterm><primaryentry>Variable</primaryentry><secondaryentry>XYZ</secondaryentry></indexterm>. Spell-check is highlighting "VariableXYZ" as misspelled. Of course, I could turn off spell-checking for index entries, but we really want them spell-checked.

Second, it's reported repeated words that have an intervening tag. For example:

Set to <lit>XYZ</lit> to activate this option.

Spell check highlights "to XYZ to" as a repeated word. Again, I could turn off warning about repeated words, but that is something we'd like to know about.

Lastly, in some instances like the index term I showed above spell-check is combining all of the words and reporting that the word is too long.

So, is there some way to configure this behavior? Anyone else experienced this? I checked the help, but couldn't find anything new concerning these new "features."

Dave Hintz
Siements
3 REPLIES 3

Hi David-


The new spell checker has a feature that checks words across inline tag
boundaries. This is probably what's messing up your index entry
checking, at least. (I'm not sure about the repeated word issue, but it
may be related as well.)



You can disable this by using "set skipinlineelements=off". There's also
a DCF setting you can use to control it for your doctype, which can
override the preferences setting if you want to prevent users from
mucking around with it. See help 17011 for more details.



--Clay


Thanks, Clay! That does the trick. One other problem we're having since 5.2 is that after so many "Ignore All" clicks, it no longer remembers these and treats them like just an "Ignore". You have to restart the editor to get it to work again. Maybe there's some buffer size that can be increased?

Dave

Hi Dave-



I'm not sure about the Ignore All thing, I haven't come across that yet.
Now that you have the index problem sorted out, maybe you won't have to
hit "Ignore All" so many times and you won't run into that upper
limit....



--Clay


Top Tags