Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - New to the community? Learn how to post a question and get help from PTC and industry experts! X

HTML Help from PE 6.0 m010


HTML Help from PE 6.0 m010

Just ran across a note in help indicating that I should contact services to
configure PE to publish HTML Help if I'm using a doctype other than
axdocbook. Uh, seriously? Has anyone got the info on what config changes
are required to enable a doctype to produce HTML Help?

I get a .chm however it's tiny and blank (although the title is correct).

Paul Nagai

Just saw that one myself recently as well and was also perturbed by that

If you've got it running, you may find some love trying to alter
htmlhelp.ccf in the composer directory. Beyond that, I've had trouble
finding details on how to configure/tweak the HTML Help output so far.

On my box, I'm not even able to select HTML Help as an option. It looks
like one should be able to install the HTML Help Workshop and then use
Styler or PE to generate HTML Help as output. However, the option is
always greyed out. Using the HTML Help preview icon in Styler to try to
fool the software, I get a message that the HTML Help Compiler is not
installed. The full workshop, latest version including the Compiler, is
however installed.

Somewhere I read in the Arbortext Help Center that you have to start the
workshop one time and close it. That didn't fix my problem.

I'm okay with being forced to use PE to generate HTML Help if that's
required, but it seems PE doesn't recognize that I've installed the HTML
Help Compiler either.

We definitely need more information on activating this feature, setting
it up with a custom doctype, and making configuration changes.



Thanks, Jason.

Although I had already looked inside of htmlhelp.ccf, just doing that did
not remind me I have an htmlhelp.ccf in my 5.3 m110 custom folder that
overrides the one in PE's /composer folder. Your e-mail triggered that
recollection. Sadly, comparing the 6.0 m010 "standard", the 5.3 m110
"standard, and the customized 5.3 m110 htmlhelp.ccf (which I think PTC
provided ... I will have to do a case search on that), is not easy. They
are all fairly different from each other and not, so far, easily understood
at least by me.


Tried running 6.0 against the 5.3 custom htmlhelp.ccf and got a dvi error.
No output at all. Well, it was worth a try, right?

We're running PE 6.0 m060 using the DITA application and I didn't have any problems enabling HTML Help. Just installed HTML Help Workshop 3.0 on the server (in the default directory on C:\), ran it once and restarted TomCat. From there I didn't have any troubles creating .chm file. Not sure if that helps at all, DITA might be one of the doc types that isn't affected by what the help says.

Hello All,
Been a while since I've been on here, and coming into this thread a little late, but...

Seems to me the key difference in Brett's post is "restarted TomCat". That was a key thing to making a change actually take effect, even in things that might not have seemed to need it. Might have been implied in an earlier post, but since I didn't see it said...

As Always, Just my $.02,
Steve Thompson


Here was something I ran into when I went to Windows 7 (and beyond J ).
For Windows 7 it is very important that this be run as an Administrator when running the HTML Help Workshop once.
How to do this for Windows 7:

1. Start →All Programs →HTML Help Workshop
2. Right click on 'HTML Help Image Editor' and select "Run as Administrator".
3. Repeat the same for 'HTML Help Workshop' as well.

The editor process looks for certain Registry entries and it may be that these are not set unless running this program in this way.

If this does not work, there are other specific things that the Composition Engine looks for to make that menu item be ungrayed.

The help looks like it may need to be updated. I run HTML Help for DITA and run it both locally and on PE.


- Dave H.

Dave Helfinstine

Thanks Steve, David, Brett, Paul. All good info.

Enabling HTML Help as an option on Windoze 7 is indeed facilitated by the Run as Administrator step shared by David. Tricksy.

Also, anyone administrating PE knows it’s a good day when you’ve bounced Tomcat. Restarting Tomcat helps commit your changes and gives you a new hope. J



Don't know if this will help since we're using axdocbook for HTML Help and not using PE. To get this running from Styler in Arbortext 6.0 M050 I found:

For publishing in Styler, PTC Knowledgebase article: "Compose/Publish for HTML Help" Menu Option is Greyed Out in Windows 7 (TAN 151574)

For viewing:

- Lou Argyres

Thanks for the ideas, folks, but so far, none of them have helped.

This is different from the known "can't run a .chm over the network" issue.
The CHM does not completely build. In my 5.3 system, it is ~0.5MB. In 6.0
it's 11k or thereabouts. It does get a proper title, so I know the XML is
meeting my XSL ... something is falling apart at the chunking and/or
reassembly steps.

I will report what PTC finds/recommends

PTC Support has replicated the issue and has R&D taking a look. I'm
crossing my fingers they are cooking me up a customized (properly
configured?) htmlhelp.ccf for 6.0.

Support identifies the problem with my use of a "legacy" .xsl stylesheet. I
originally exported it from 5.2 Styler and have been maintaining it
separately since. It survived the 5.2 > 5.3 upgrade (at least it worked ...
I can't remember if I had to modify it to accommodate changes or not). It
is not going to survive the migration from 5.3 to 6.0.

I will have to delete all XSL source edits from my 6.0 styler stylesheet
(which I don't use but were put in and dutifully migrated from 5.2 to 5.3
to 6.0) and go with that. I haven't verified that this will work yet, but
that's the guidance I've been given.

Looks like I'm going to use my soon-to-be decommissioned 5.3 environment
for a few more publications.

If you haven't seen my Win7 / WDK adapter thread, it turns out I am running
64bit Editor with a 32bit Java environment. I haven't verified it is the
cause of the issue behind that thread, but I'm going to uninstall Editor
and reinstall the 32bit version. No one has suggested that issue relates to
this issue, but just in case, if you're in Win7 on a 64bit machine / OS,
you might want to verify ALL your apps are 64bit if you're having troubles.

I can now confirm that PTC told me true ... strip all HTML Help source
edits from the Styler stylesheet ... and the CHM will be returned to you.

Of course now I have the joy of redeveloping my years of XSL HTML Help
development in Styler 6.0 natively or adding each source edit back one or
two at a time verifying that they "work" and "fixing" only those that break
the 6.0 model. Or some time-driven combination of both. Hoom homm.

Thanks PTC for ensuring job security for years to come 😉

John Sillari
Top Tags