cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

PE interactive problem

ptc-953926
1-Newbie

PE interactive problem

Adepters:


I’ve got a strange problem with PE 5.3. I recently added an entirely new doctype to our custom DocTypes folder and an entry in the catalog file pointing to the new doctype. After restarting/rebooting the server, I’m able to successfully generate direct-to-PDF using our normal process for sending print jobs to PE. However, when I open the source XML file in PE Interactive (which opens the file without errors and points to the doctype in all session information variables) and try to Print Preview or Compose > PDF file, I get an error window with this message:


[A20448] Document type not installed on the PE server. Check the server’s catalog path setting.


Anyone know how to get past this? I can print preview and compose PDF with any of our previously existing doctypes – just not this new one.


Thanks,


Dave

5 REPLIES 5

Does setting peservices=off change behavior?


Hmmm... That seemed to cure it. I don't understand why older doctypes worked with peservices set to on...

Not a lot of help predicting the next outcome ... but I have this vague
recollection that different things are refreshed by an f=init call, a
Tomcat restart, and an OS restart. I even more vaguely remembering some of
those things differ between Arbortext versions.



If you have a look at the "peserverurl" preference you will find which other PE server that your PE Interactive was trying to connect to when peservices=on ...

-G

Were you able to open the PE Composition Information and see if this document type appeared?

Another (long shot) issue... Did you define any composers (ccf files) in the DCF file? Should be a Composition element with one or more Composer children, and they correspond with the CCF files used for HTML, xsl-fo, PDF, web composition. You might be getting weird results if there are no composers defined.
Announcements