Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you know you can set a signature that will be added to all your posts? Set it here! X

Weird FO stylesheet problems, also 5.1 v 5.3 v 5.4


Weird FO stylesheet problems, also 5.1 v 5.3 v 5.4

I was asked to help out with a problem at work. I've been able to
work with this stylesheet a little but I probably don't have all the
information I need.

Anyway, the group I'm supporting downloaded some FO stylesheets from
the Army site ((40* something milspec). It appears they have content
they have created and are now trying to produce with Print Composer.

They sent me a sample document they were having problems with. My
first observation was that the stylesheets were generating errors.
These were exported from styler and were highly modularized. There
were some warning about multiple rules matching that were ok, but
there were other XSL errors.

Anyway, they had been able to print this sample with Print Preview
(using 5.1) but they were having problems using Compose directly.
That turned out to just be a configuration detail to turn on select
stylesheets. The other issue they had was trying to get the graphics
appear in the PDF. So they bundled the files up and sent it to me.

I first tried using Print Composer in 5.4 and that completely failed
with XSL errors. I tried running the stylesheets in Saxon and it
failed with XSL errors. These guys were able to print preview with
5.1 - how come? I tried to use my 5.3, this time it printed and I got
the graphics. None of the XSL errors were reported - how come?

I had made a couple of configuration details, generated a DCF file
and such and bundled all these files up and sent them back. I'm
trying to get better details of what they did next; its confusing if
they were able to get the document to print that I sent back or not.
Anyway, they have at least added or modified content in the sample
XML file. Now when they compose with Composer it throws an assertion
error and fails. If they remove what appears to be an empty element
it works again.

Anyone seen assertion errors from composer and know of a way to track
the problem down? I've suggested that because the stylesheet is
technically broken (but for some reason working in different versions
of Editor) that the place to start is with fixing the stylesheet. I'm
thinking the new content is triggering a template rule that wasn't
used before and that is triggering a problem in Composer.

They don't seem to have the skills to work on the stylesheet, I
suggested that they try and use Saxon and see if Apache FO would work
or throw some more useful errors. I'm hoping they get some funds so I
can really dig into the problem but that may take time. My last
suggestion was to divide up the document and narrow down where the
problem is, they may have done that today.

While trying to work on this, I was trying to load these stylesheets
back into Styler. Is there any way to import an FO stylesheet? I was
looking for options but it seems to be hardwired to only work with
FOSI format on import. I was hoping it might help fix the stylesheet problems.

Any suggestions welcomed, this has been a real puzzler that I haven't
been able to really dig into very deeply due to the funding. I've
never worked with FO in Arbortext, I've always done this with third
party tools like Antenna House and RenderX.