Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Stay updated on what is happening on the PTC Community by subscribing to PTC Community Announcements. X

default_dim_num_digits_changes in WF5?


default_dim_num_digits_changes in WF5?

Any idea what's default_dim_num_digits_changes used for? In WF5, it causes negative dimensions to be rounded during 'edit definition'. See short video attached. Rather dangereous, since the actual distance between the two planes is rounded, in the video from -5.5 to -6!!

Regards, Hugo.

23-Emerald III

I googled it and this is one thing I found. Maybe your default_dec_places is set to zero so when it is no, it default to zero decimal places. Just a thought.


yes, no

sets the default number of digits displayed in a dimension to the last entered value. if you set this option to no, the system defaults to the value specified for the configuration file option default_dec_places.

Thank for your reply.

Our "default_dec_places" is set to 3, and even then, why would ProE act different for negative values then positive ones??

Anyway, the problem is solved by setting default_dim_num_digits_changes to yes. My posting is mostly intended to warn admins to check their environment, and eventually to check their designs. We checked several of ours, and found a few issues due to this behavior.

The option is pretty clear but the video is what is disturbing. The option is -suppose to- either show all relevant digits or only the number of digits defined by the default_dec_places option. So if you were to obtain a dimension though a calculation, and it rounds out to 6 digits, it will display all the relevant digits if the option is set to no.

I think something else is going on in the video as it did take the value correctly at one point.

Just for the record (and a little bit because I'm curious about this):

- I started ProE WF5 M140 (actually Creo Elements/PRO) without any option, so clean out-of-the-box

- I added the option 'default_dec_places 3'

- I added the option 'default_dim_num_digits_changes no'

- I started a new empty part

- I created 3 datum planes, DTM1, DTM2, DTM3. DTM3 stayed selected.

- I created an offset datum plane from DTM3, beiing DTM4

- I changed the offset value to -5.5

>>> the 'Datum Plane' dialog box gives 6 as value ... 😞

- Done / OK

>>> measuring the distance between the planes gives 5.5 ... 🙂

- I selected DTM4

- I selected 'Edit Definition', and added '+5' to the offset value

>>> the 'Datum Plane' dialog box gives 11 as value ... 😞

- Done / OK

>>> measuring between DTM3 and DTM4 gives 11 instead of 11.5 ... 😞

I just went through all the steps as you did in Creo 2.0 M010. No dice. Everything worked as expected including seeing 3 digits in the dialog and accurately moving the plane as it is told to. You found an unusual bug.

I can confirm this. In Creo 2.0, the problem can not be reproduced. Thank you Antonius.

Business Continuity with Creo: Learn more about it here.

Top Tags