cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

J-Link demos not working

ptc-4044267
1-Newbie

J-Link demos not working

I am trying to get the J-Link demos included with the the Tryout Edition but I cant seem to get them to run. When I try to run them I get the following error, type ABS; Foreign program "InstallTest" failed to initialize: error PRO_TK_GENERAL_ERRORException - code was -1073741819. Any suggestions? Thanks Marc
6 REPLIES 6

Marc, What Operating System and Java version did you compile and test with? Carl

I am on Windows XP Pro. I compiled the code with java version 1.4.2. I do have a couple different java versions on my PC so I am wondering if ProE is using one version while I complied with another. I also read that ProE comes with its own JVM so it might be older then the version I am using. I havent seen if I can (1) tell Proe to the java install I have or (2) use the java install with Proe to compile the code. Thanks Marc

Marc, I usually use a batch file to set environment variables and launch Pro/E. Something like: 😧 cd\ cd proeWildfire\install_test SET CLASSPATH=. SET PRO_JAVA_COMMAND=java "C:\Program Files\proeWildfire 2.0\bin\proe1.bat" You can adjust this to your directories or just try from the command line. You can check which java version on the command line by: java --version Carl

Hello Make sure that you have the below environment variables set correctly. CLASSPATH = <ProE Loadpoint>\text\java\pfcasync.jar PATH=<ProE Loadpoint>\i486_nt\lib PRO_COMM_MSG_EXE=<ProE Loadpont>\i486_nt\obj\pro_comm_msg.exe Check your protk.dat file that it has the correct paths to the java main class file. If you have the protk.dat file and environment variables set correctly then the application should run. If you have any more question please email me at jfelkins@felcosolutins.com and I do offer a J-Link course if you are interested. Good luck. J.D. Felkins

Hello Make sure that you have the below environment variables set correctly. CLASSPATH = <ProE Loadpoint>\text\java\pfcasync.jar PATH=<ProE Loadpoint>\i486_nt\lib PRO_COMM_MSG_EXE=<ProE Loadpont>\i486_nt\obj\pro_comm_msg.exe Check your protk.dat file that it has the correct paths to the java main class file. If you have the protk.dat file and environment variables set correctly then the application should run. If you have any more question please email me at jfelkins@felcosolutins.com and I do offer a J-Link course if you are interested. Good luck. J.D. Felkins

Thanks for everyones help. I was able to get it to work by setting all the env vars you recommended and then starting Proe. Thanks Marc
Announcements