cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mathcad 13 won't launch

MoeSzyslak
4-Participant

Mathcad 13 won't launch

All --

I had a v13.1 installation on my laptop. Worked fine for a couple of years, no problems at all. For a reason I can't seem to pinpoint, it just stopped working. If I double click on a Mathcad file, I get a Windows (XP) "file not found" error. If I click on the start menu shortcut for Mathcad, nothing happens. If I double click on mathcad.exe or mcad.exe in the installation folder, nothing happens.

I tried a repair, but that didn't solve the problem. So, I performed a complete uninstall removed everything mathcad/mathsoft/mcad from the registry, rebooted, and then tried a new installation of v13.0 (antivirus and Windows Defender turned off). Still have the same problem.

Any ideas?

Thanks.

Matt
8 REPLIES 8

On 8/15/2008 5:12:26 PM, Moe_Szyslak wrote:
== I had a v13.1 installation on my laptop. Worked fine for a couple of years, no problems at all. For a reason I can't seem to pinpoint, it just stopped working. If I double click on a Mathcad file, I get a Windows (XP) "file not found"

By coincidence, I've got a similar problem. I'm getting the Visual C++ library 'runtime error' (eg, http://collab.mathsoft.com/read?111791,99 ). It's taken out M12, M13 and M14. The applications were all running fine, with no subsequent installations or repairs, earlier on in the week (so all the pre-requisites were there).

However, I note that Windows has done 2 updates and I installed the update to Norton 360 a couple of days ago.

I've tried the usual Repair route on all of them and a few of the other suggestions. Before I consider re-installing them (a major PITA), I was wondering if anyone had any ideas what could be common to all 3 versions? (M11 and M7 seem to be OK).

Stuart


All mine works fine (v11.1, v13.1 and v14.011M) and my Windows is updated. On the other hand I avoid any Norton stuff, so I can't tell if there is something there.

Steen Gro�e

Try turning off Norton Antivirus protection.

Here are some other suggestions from technical support database:

Cause1: During the start up process, Mathcad searches for the default printer to use so if the default printer is unavailable e.g. when a laptop is not connected to the network, it can cause a delay.

Resolution1: Ensure that the default printer is available prior to launching Mathcad.



Cause2: Mathcad looks for a license server that is no longer used to issue licenses

Resolution2: Check the registry for details of where Mathcad is looking for the license server. The server details are stored in

HKEY_CURRENT_USER\Software\Mathsoft\Mathcad 13\FLEXlm

Under the FLEXlm key, on the right-hand-side, check that the server (or servers) listed is available and remove any that are no longer in use.



Cause3: It is possible (although unsupported) to set registry entries to look for handbooks and templates too (see Networked Handbooks and Templates (unsupported) for more information).

Resolution3: Ensure that the network locations specified in the registry are accessible prior to launching Mathcad.

Make sure that you are not being blocked by "spyware" and AntiViruses software.

Mona

Any luck resolving this issue? I had a 13.0 installation that worked fine up until about a week and a half ago. There were some windows and Lenovo updates installed, and since then, I get the following message whenever I try to open any handbook or mathcad document:
"Windows cannot find 'C:\...path to document I'm trying to open'. Make sure you typed the name correctly, and then try again. To search for a file, click the Start button, and then click Search."

If I try to start the executable either directly from the program files directory or from the start menu, it does nothing (or runs & terminates with no message). I have tried uninstalling and reinstalling the program with no joy. I did not uninstall all the handbooks or muck about with the registry. I did try installing the 13.1 upgrade but it would not complete, saying it couldn't find something with the existing installation. I am in the middle of generating some design info and it has shut me down.

Any suggestions? Thanks,
Jon

I just ran into this problem as well. Last used it on this PC two months ago, and it was working fine. Now, nothing, and no error messages (unless I click directly on a M13 file, and then I also get the "file not found" error).

Something changed in Windows and it really messed this up.

jp

If that is the case there might be one of two things you can do about it (assuming you don't have a full backup system in place that can restore your system to a known point in time):


1) Go to Automatic Updates section in control panel and make sure that updates don't install automatically - only notify.

Then go to your Add/Remove Programs secion in control panel. From there you should be able to find a listing of all Hotfixes and Patches that have been applied to your system. Record them and then remove them one-by-one starting at the most recent. Test mathcad each time (maybe even re-boot every couple of patches you remove). You will find the hotfix/patch that did the damage and will know not to let it install again.

Then make sure you go to windows update and install all the other patches/hotfixes except for the one you identified. If you never found one, still go to windows update and get all your updates again.

If you do find that one was the problem - let us know.

2) See if you can do a registry restore to the last time you knew it worked. Google that if you need to. If you don't have luck - or the ability to restore to then try this AFTER backing up your registry (messing around in the registry can cause big problems if you are not careful):

Do a complete uninstall. Do a registry Then open up the registry (Start->Run->RegEdit) then do a "find" on Mathcad and remove all entries. Similarly do a "find" on Mathsoft and remove all entries.

Then re-install Matchad - and I would suggest installing to a new location.

That should be as close to a "fresh" install as you can do on an existing system.


Philip
___________________
Correct answers don't require correct spelling.

It might also have to do with the activation server at PTC.

If so, contact PTC activation at 781-370-5205 in North America


or 00800 PTC-4-HELP
(00-800-78-24-43-57) in Europe,

See http://www.ptc.com/support/mathcad_contacts.htm

Mona

I periodically have trouble where mathcad 13 won't launch. One thing to check in windows xp:

Type services.msc into the run box.

Scroll down to the service C-DillaCdaC11Ba and make sure it is started. If it is not running, start it up. Some malware search programs turn it off apparently, and mathcad 13 does not like that.

Announcements