cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

Assignment trigger meant to clear rich-text is configured with MKS HTML tag and a non-breaking space

BaluSri
6-Contributor

Assignment trigger meant to clear rich-text is configured with MKS HTML tag and a non-breaking space

Most of the assignment triggers in our environment that are meant to clear/blank out a rich-text field are configured to a value like "<!-- MKS HTML -->&#160;". Not sure why the consultants put it in there.

Is this necessary? Why not just clear it to a blank value? Reached out to PTC Support, but nothing helpful so far. 

2 REPLIES 2
kjain2
14-Alexandrite
(To:BaluSri)

Hi @BaluSri 

 

Generally when we set value in rich text field and that value contains any style then prior to that value we use "<!-- MKS HTML -->". But it's not mandatory to use "<!-- MKS HTML -->" if value is simple plain text without any style we can also go without "<!-- MKS HTML -->".

 

Assuming your question, Assignments trigger are written to set blank value in your environment on rich-text configured longtext field.

"&#160;" is the code used in HTML to give non breaking space between text instead of using space.

 

So long story short your assignment triggers are not setting blank value although it looks like blank but it's not actually. There is a space inserted in each value because of this code "&#160;". Please check the agenda behind that if there is no other things affected with this space then you can also go in assignment trigger with an empty value. Hope it helps?
Feel free to reach me out in case of any question.

Vielen Dank / Many Thanks,

Kapil Jain

BaluSri
6-Contributor
(To:kjain2)

I was checking to see if I can clear the rich text field to blank, but unfortunately, in an assignment trigger, the system defaults to "<!--MKS HTML-->&#160;" when you add any rich-content field, even if you explicitly leave the field blank. 

Tested this in Integrity 11.2 and RV&S 12.4. Not sure why I can't find any documentation of why this is the default. Tech Support don't seem to have an answer either.

Top Tags