cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Can we create a user when there a admin lock on the server

Shree
5-Regular Member

Can we create a user when there a admin lock on the server

Hi guys ,

As all we know,when the user are logged into integrity user details will automatically imported from the LDAP.

There will be some user like business owner.. this kind of  user doesn't have any business with Integrity. But we need there details to display in integrity. So its not good idea to say them please login into integrity. So have wrote the code to add the user into integrity. Now the issue is we can't create the user when server has admin lock on the integrity.

 

So now i need to create a user when there is admin lock on the server .If it is not possible can we automate a migration process. like dev to staging ,staging to production . Does any one has any idea about this.

 

Thanks

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
MichaelChatel
19-Tanzanite
(To:Shree)

The property is available in 10.7 too.  Here's a screenshot showing where in the Admin GUI you can find it.  If you still don't see it, I'd suggest opening up a Support case, as perhaps your server is mis-configured or something else is going on.

 

screenshot_property.jpg

View solution in original post

5 REPLIES 5
MichaelChatel
19-Tanzanite
(To:Shree)

Hi Shree,

 

You likely want to check out this knowledge article;

 

https://www.ptc.com/en/support/article?n=CS91512

 

Since Integrity 10.5, we've had the "mksis.im.allowPrincipalCreationOnLockedServer" property, that one can set, to allow users to be created on a locked server in an admin staging environment, where there is a need for it.

 

 

Shree
5-Regular Member
(To:MichaelChatel)

This property is not there in 10.7 version. is there any other way.

MichaelChatel
19-Tanzanite
(To:Shree)

The property is available in 10.7 too.  Here's a screenshot showing where in the Admin GUI you can find it.  If you still don't see it, I'd suggest opening up a Support case, as perhaps your server is mis-configured or something else is going on.

 

screenshot_property.jpg

View solution in original post

Shree
5-Regular Member
(To:MichaelChatel)

Thanks for the valid reply, Thanks you guys

kjain-2
15-Moonstone
(To:Shree)

Hi @Shree,

 

You can handle this scenario by setting some properties using GUI as well as CMD command as @MichaelChatel also said. Please take a look over the article and i hope this will definitely solve your issue.

 

Regards,

Kapil 

Announcements