cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

SOLVED
Granite

In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

Hi All,

I am Using Windchill 10.1 with jre 7.0 Build 25.

when i open a workflow editor, i am not able to see the selected Robots in Editor area.

Normally when we create a new Workflow, it opens a Workflow editor with Start Robot.

we acn put the required Robots in to Editor area and some logic to them.

but in my case when i open a new workflow editor it opens but not showing start robot..if i try to put any robot in editor area it opens but it is not visible.

same if i try to view existing OOTB worklfows in editoe it gives me Blank editor and if i click randomley in area then the robots are opens in Pop ups but they are not visible .

i check the java versions. it is as per PTC's Recommadations.

here are two fig which howing the differeance.

This is the Actaual WF editor which normaly opens.

WF_Editor+With+Start+Flag.jpg

This is the WF Editor on My system without Start Flag.

WF_Editor+Without+Start+Flag.jpg

Please suggest the solution.

Thanks,

Vivek

1 ACCEPTED SOLUTION

Accepted Solutions

Re: In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

I woudln't even bother messing with Java permissions unless the Java console indicates a security exception.

Moreover, one shouldn't have to mess with Java permissions except as a temporary workaround. If messing with permissions solves the issue, then that's an indication that something should have been fixed -- and probably that you're lacking the latest generic patch for such issues. [As Java Plug-In security updates come out, code sometimes needs to be adjusted to work around behavioral changes made by these updates in the name of security.]

I cannot reproduce your issue, but I suspect it has as much chance of being a compatibility issue between Java and your video driver as anything else. You can try disabling the Java Plug-In's attempts to use video acceleration by adding "-Dsun.java2d.noddraw=true" to the JVM options via the Java Plug-In's control panel. See http://docs.oracle.com/javase/7/docs/webnotes/tsg/TSG-Desktop/html/java2d.html for more information.

View solution in original post

7 REPLIES 7

Re: In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

Hello,

It result of the java console.

Add this line in this file :

permission java.net.SocketPermission "ipserverwindchill:*","connect";

C:\Program Files\Java\jre6\lib\security\java.policy

Regards

Pascal

Re: In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

Hello Pascal,

Thanks for u help.. As per instructions i put "permission java.net.SocketPermission "ipserverwindchill:*","connect";" line in the java.policy file and restart the system.

Unfortunatly problem is still there..

for u r more information i pasted the java.policy file here...

java.Policy

--------------------------

// Standard extensions get all permissions by default

grant codeBase "file:${{java.ext.dirs}}/*" {

permission java.security.AllPermission;

};

// default permissions granted to all domains

grant {

// Allows any thread to stop itself using the java.lang.Thread.stop()

// method that takes no argument.

// Note that this permission is granted by default only to remain

// backwards compatible.

// It is strongly recommended that you either remove this permission

// from this policy file or further restrict it to code sources

// that you specify, because Thread.stop() is potentially unsafe.

// See the API specification of java.lang.Thread.stop() for more

// information.

permission java.lang.RuntimePermission "stopThread";

// allows anyone to listen on un-privileged ports

permission java.net.SocketPermission "localhost:1024-", "listen";

// below line added after Workflow getting an error

permission java.net.SocketPermission "ipserverwindchill:*","connect";

// "standard" properies that can be read by anyone

permission java.util.PropertyPermission "java.version", "read";

permission java.util.PropertyPermission "java.vendor", "read";

permission java.util.PropertyPermission "java.vendor.url", "read";

permission java.util.PropertyPermission "java.class.version", "read";

permission java.util.PropertyPermission "os.name", "read";

permission java.util.PropertyPermission "os.version", "read";

permission java.util.PropertyPermission "os.arch", "read";

permission java.util.PropertyPermission "file.separator", "read";

permission java.util.PropertyPermission "path.separator", "read";

permission java.util.PropertyPermission "line.separator", "read";

permission java.util.PropertyPermission "java.specification.version", "read";

permission java.util.PropertyPermission "java.specification.vendor", "read";

permission java.util.PropertyPermission "java.specification.name", "read";

permission java.util.PropertyPermission "java.vm.specification.version", "read";

permission java.util.PropertyPermission "java.vm.specification.vendor", "read";

permission java.util.PropertyPermission "java.vm.specification.name", "read";

permission java.util.PropertyPermission "java.vm.version", "read";

permission java.util.PropertyPermission "java.vm.vendor", "read";

permission java.util.PropertyPermission "java.vm.name", "read";

};

Re: In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

Hello,

Did you change "ipserverwindchill" on ip adress winchill server ?

Example : 168.100.10.10

Regards

Pascal

Re: In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

I woudln't even bother messing with Java permissions unless the Java console indicates a security exception.

Moreover, one shouldn't have to mess with Java permissions except as a temporary workaround. If messing with permissions solves the issue, then that's an indication that something should have been fixed -- and probably that you're lacking the latest generic patch for such issues. [As Java Plug-In security updates come out, code sometimes needs to be adjusted to work around behavioral changes made by these updates in the name of security.]

I cannot reproduce your issue, but I suspect it has as much chance of being a compatibility issue between Java and your video driver as anything else. You can try disabling the Java Plug-In's attempts to use video acceleration by adding "-Dsun.java2d.noddraw=true" to the JVM options via the Java Plug-In's control panel. See http://docs.oracle.com/javase/7/docs/webnotes/tsg/TSG-Desktop/html/java2d.html for more information.

View solution in original post

Re: In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

I had a similar problem, it was fix by adding runtime parameters to user and systemjava.gif....see photo.

Re: In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

I'm trying to insert the parameters provided above, but the Java Control Panel is not allowing me to save the change. I have tried as admin so I doubt it has to do with permissions. Any ideas as to what is preventing me from adding the parameter?

Re: In Windchill 10.1,Workflow Editor not Showing Robots in Editor Area

Resolved by inserting a different video card.

Announcements
LiveWorx Call For Papers Happening Now!