cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

LineNumberUsageException Recieved even if the Line Number is completed

SOLVED
Highlighted
Garnet

LineNumberUsageException Recieved even if the Line Number is completed

Hi all,

 

We are receiving the following exception when publishing with ESI:

2020-01-07 07:55:55,967 ERROR [SessionThread-6] com.ptc.windchill.esi.tgt.delegate.DefaultESITargetProcessor - Error while invoking ESIResponseGenerator.generateResponse:
com.ptc.windchill.esi.rnd.ESIRendererException: (wt.part.partResource/170) wt.part.LineNumberUsageException:wt.part.LineNumberUsageException: At least one component of "Component - xxxx, Name, Organization, B.3 (Manufacturing)" does not have a line number. 

 

 Line numbers are filled and the Enforce Line Numbers preference is set to No. 

 

Any ideas why this happens or any ideas on how to fix this?

 

Alex 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: LineNumberUsageException Recieved even if the Line Number is completed

Hi Alex,

 

What version of Windchill/ESI are you seeing this with?

 

I wonder if it's something like the scenario, mentioned in this knowledge article,

https://www.ptc.com/en/support/article?n=CS35247

 

Where the Enforce Line numbers preference expects that either all or no components have line numbers, may maybe you have a mix here?

 

You may want to open a Support case, where one of the ESI knowledgeable engineers can assist you.

 

Mike

 

View solution in original post

2 REPLIES 2

Re: LineNumberUsageException Recieved even if the Line Number is completed

Hi Alex,

 

What version of Windchill/ESI are you seeing this with?

 

I wonder if it's something like the scenario, mentioned in this knowledge article,

https://www.ptc.com/en/support/article?n=CS35247

 

Where the Enforce Line numbers preference expects that either all or no components have line numbers, may maybe you have a mix here?

 

You may want to open a Support case, where one of the ESI knowledgeable engineers can assist you.

 

Mike

 

View solution in original post

Re: LineNumberUsageException Recieved even if the Line Number is completed

Hi Michael,

 

We checked before if any Line Numbers are missing but everything was in order. 

I set the Enforce Line Numbers Preference to Yes then back to No and restarted the server during the night.

It seems somehow this helped and i was able to publish in the morning. 

 

As we are still on Windchill 10.2 M030 PTC support will close the case as this version is no longer valid for support. We are upgrading to 11.1 but the process will take some time. 

 

Alex

Tags (1)
Announcements
LiveWorx Call For Papers Happening Now!