cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

Problem using "Percentage unit" in quantity of measure

prelard812
3-Visitor

Problem using "Percentage unit" in quantity of measure

Hi, 

In our windchill server, We got some Classification that use a defined "Tolerance Attributes" using the "percentage" unit.

This "percentage" unit is defined into "Qty of measure menu" as "override" =  % into all Measurement system.

Seems good at first but when we set a part with attribute tolerance lets say to: 5 to get 5% tolerance.

When the part is display after the creation the Tolerance attribute is display = 0.05 %

 

I look into the documentation but I was not able to find a default unit equal to the percentage sign(%) is like that % unit is not standard but I can't find where it could be define elsewhere.

 

How can I get the % sign for the attribute but got the displayed value not divide by 100. 

Thank you. 

5 REPLIES 5

We have currently the same issue. Does your issue have been solved ? Does anyone have an idea ?

Many Thanks

BenLoosli
23-Emerald II
(To:prelard812)

Someplace in the Unit of Measure settings or maybe the Preferences for the display to show the right values.

I had to change some preference for my weight to show pounds in Windchill and Creo. Originally Creo showed pounds but Windchill converted it to kg when the file was checked-in. Changed the preference for display units and all is good now.

Excel does something similar. If you define a cell as a percentage, you need to enter .05 to get it to display 5%.

Hey prelard812,

 

I suspect you are probably seeing the behaviour mentioned in this knowledge article, and known SPR.

https://www.ptc.com/en/support/article?n=CS269201

 

Depending on the Windchill version/CPS you are on, there may be a fix for it.

 

You may want to open a Support case, if it's not the issue in that article - but it sounds like it probably is.

 

Did you find out more about this?  Was it related to the article I mentioned?

Hi Michael

yes it works now... ( It seems!!!) 

And your documentation was right.. it seems to be a problem from our server migration from version 8 to 11 ~two years ago. 

 

So to conclude it seems to be related to system of measure.  We delete the Percentage sign from all system of measure / save and reedit the % sign in the same field and it seems to fix the problems now.

Thank you for your support 

Top Tags