cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Contributor

Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Hi all,

I'm trying to integrate Creo 3.0 M080 and Auto CAD 2016 with Windchill PDM Essentials 10.2 M030 (CPS13) but getting error " Invalid server location".

We've Windchill url like abc.xyz.com:81/Windchill. We're using port 81 for web server.

We're able to access windchill through browser with out any problem but  unable to do CAD integration.

I'd like to mention that we're not using VPN to access Windchill server and default browser for Creo is IE.

Kindly help me out.

Regards,

Krishna Chaithanya.

8 REPLIES 8

Re: Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Try clearing all the browser and Creo caches. Also go through Apache error log and MS log, there should be some additional information on this.

Thanks

Binesh Kumar

Re: Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Hi Binesh,

Thanks for your reply. I'd cleared all browser caches. But, still  facing the same problem.

I've gone through Apache error log, there I found below errors..

error.jpg

Regards,

Krishna Chaithanya

Re: Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Hi Krishna,

There is something wrong in the webserver configuration unless you see anything wrong in the method server logs. See this https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS22127

Regards

Binesh Kumar

Re: Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Krishna,

Did Binesh's latest suggestion help? Were you able to get them registered?

Re: Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Hi Lori Sood,

I could able to find that there is an error in Info Engine Configuration. When I've checked in Windchill>Site>Utilities>InfoEngine Administrator, it showing an error at Info Engine Adaptor. Finally I've tried to telnet 10002 port from client machine but could not able to do so. Realized that 10002 is not available. So searched for 10002 if used by any other application, but unable to find that range of ports in server(10002 to 10010). Then allocated other available port (other than 10002 to 10010) to Info Engine and the error in Info Engine is resolved.

But still registration is not possile as Creo is getting hanged while trying to register.

Regards,

Krishna

Re: Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Hi Binesh,

I'd like to know whether the registration of Creo is possible With Windchill if we assign ports other than default(10002-10010). Because in my scenario, we've given another port range (10025-10035) as default ports are not available(here searched by netstat but could not find that range. Tried to open them but came to know that no fire wall is enable to block respective ports). So, Creo registration is not getting possible. Please clarify.

Regards,

Krishna Chaithanya

Re: Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Krishna,

Would it be possible to use Fiddler to capture the network traffic that is occurring when you attempt to register the server?

Have you opened a tech support case for this?

Re: Unable to register Creo and Auto CAD with PDM Essentials 10.2 M030

Hello Krishna,

How did you change the port number for Info engine? Do you have multiple method servers? Did you change it from the below Window?

Screen Shot 2016-05-14 at 11.39.52 AM.png

Verify it in LDAP too

Screen Shot 2016-05-14 at 11.49.01 AM.png

Could you compare the repositories in Task Delegate Administration with what I have below? I remember facing a similar issue while I was supporting a customer. Verify the repository type, webject processor and task processor

Screen Shot 2016-05-14 at 11.40.59 AM.png

For LDAP adapters, this  repository type should be windchill-ldap

Screen Shot 2016-05-14 at 11.40.33 AM.png

If you don't catch any differences - try increasing the Method Server to 2, this should create an additional adapter and see how the works (in wt.properties, wt.monitor.startMethodServer to 2, verify the syntax of the property)

Regards

Binesh Kumar

Medtronic - MITG

Announcements
LiveWorx Call For Papers Happening Now!