cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Welcome to the Windchill Performance blog

Regular Member

Welcome to the Windchill Performance blog

Welcome to my blog.  I'm Stephen Vaillancourt and work in PTC Technical Support in the Technical Leaders group.  I've been around since the Pro/PDM days, and first started working with Windchill around release 5.  I initially supported out of the box functionality and customization for the Windchill R5-R8 releases.  In the last several years I've concentrated on diagnosing Windchill Performance and stability problems. At one time a good portion of the Windchill performance and stability problems used to funnel through me; in recent times I've helped train a group of people around the world who now work on these problems and it’s primarily with these TSE’s I now work in a backline capacity on some of the more difficult problems.

Over the years I’ve worked on thousands of Windchill performance problems and I know the pain, frustration and lost productivity that can be caused when the system isn’t working right.   I'm hopeful that some of the information in this blog will help prevent those problems or if they do occur to help get them resolved more quickly.

If there are topics you would like see discussed in this blog, I’m interested to hear you ideas.

Stephen



4 REPLIES 4

Re: Welcome to the Windchill Performance blog

I am looking for an answer to a problem. I just installed dual Tomcat Services on a 32bit windows 2003 Server running PDM 9.1 M060. When I search with both services running I get an error "Your session data has expired. If I shut either one down the search works fine.... Any ideas?

Re: Welcome to the Windchill Performance blog

I'd try adjusting the 'session-timeout' value from the default of 30 to maybe 60 or 90 in the <Windchill>\Windchill\codebase\WEB-INF\web.xml file.  If the same problem continues to occur I’d open a TS case to review the dual Tomcat configuration.

Highlighted

Re: Welcome to the Windchill Performance blog

Stephen,

We're running WC PDMLink/ProjectLink 10.1 M040 with Creo 2 Parametric M070.  Very often users will see the error message, "The server is currently unavailable. Do you want to switch to offline mode?".  The majority of my users have issues with using the workspace in the embedded browser (IE) where they'll get the spinning wheel for a minimum of 5 minutes up to an hour.  From a support standpoint we're looking at the client workstation, DB & App servers, and the network.  Can you suggest some thing(s) to check that may give us a better idea of what to do next? 

Thank you,

Nadeem

Re: Welcome to the Windchill Performance blog

Nadeem,

I checked with Matt Banik on your question.  His thoughts are below.

---------------

We would start with a review of the Apache KeepAliveTimeout per CS19706 .

Other general items to check are initial server performance settings CS24192 and initial client performance settings CS23960.

After those we have a couple of specific issues to look at:

CS155061 - “The server is currently unavailable“  due to browser instability, first reported against Creo 2.0 M060 & M070 fixed at M100.

CS126473 - Internet Explorer specific spinning progress icon on Windchill pages

Once past those issues I'd open a case to troubleshoot further with a TS case.