cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Windchill Apache Error while adding users in Product/Library Team

TanviYeotikar
1-Newbie

Windchill Apache Error while adding users in Product/Library Team

Hi All,

I am trying to add new users in a Product/Library Team with Admin login. But while adding users I am facing an issue as shown below:

org.apache.jasper.JasperException: /netmarkets/jsp/principalpicker/principalPickerCD_step.jsp(61,1) File"/netmarkets/jsp/principalpicker/principalJS.jspf" not found

I am unable to resolve this. Can anyone help me out to solve it & also suggest reason behind this error.

Regards,

Tanvi

1 ACCEPTED SOLUTION

Accepted Solutions
jessh
5-Regular Member
(To:TanviYeotikar)

Running the Windchill server on Java 7 is not supported until version 10.2 (at which point Java 7 is required on both client and server), so I hope you're not actually doing that.

The JIT issue I was referring to impacts old versions of Java 6 after the system has been in use for quite some time or very heavy use for a shorter time. That issue was reliably resolved (for a while) by restarting the servlet engine JVM (the method server in 10.x or the standalone Tomcat in previous versions).

View solution in original post

3 REPLIES 3
jessh
5-Regular Member
(To:TanviYeotikar)

I do not know the resolution, but I can say that this has nothing to do with Apache.

Which version of the software is this? Which Java version is the server running with? [This looks somewhat like a JIT issue in old versions of Java 6, but could be something completely different.]

Hello Jess,

Thank you so much for your guidance. Windchill Version is 9.1 M050 and Server is running on the Java Version 7 Update 51 (build 1.7.0_51-b13).

I would like to ask few more questions, Does this happen due to heavy load on server or the incompatibility of the version?

Because sometimes when I clean the cache memory & restart the server then system works properly. But this issue did not get resolved even after clearing cache.

Regards,

Tanvi.

jessh
5-Regular Member
(To:TanviYeotikar)

Running the Windchill server on Java 7 is not supported until version 10.2 (at which point Java 7 is required on both client and server), so I hope you're not actually doing that.

The JIT issue I was referring to impacts old versions of Java 6 after the system has been in use for quite some time or very heavy use for a shorter time. That issue was reliably resolved (for a while) by restarting the servlet engine JVM (the method server in 10.x or the standalone Tomcat in previous versions).

View solution in original post

Announcements