cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Workflow variables are getting reset automatically.

hsha1102
Marble

Workflow variables are getting reset automatically.

Hello All,

 

I have certain workflow variables, for example status, using which I will determine whether a process is succeeded or not. Once an activity fails it will trigger a user activity where they will perform some changes on the data. In some cases after taking the failure path the variables are then getting reset automatically. I have used loop link in the workflow. Can anyone please explain what is the problem here and how to resolve it. 

 

Thanks in advance.

 

Please refer the attachment.

1) Initial activity

2) If validation fails, "E" path will be taken. E is the value of the workflow variable status.

3) User activity

4) Loop link

 

In my case the user has not completed the failure activity i.e. 3 is not yet completed but still the variable values were reset.

 

Regards,

Hari Shankar

3 REPLIES 3

Re: Workflow variables are getting reset automatically.

Hello,

you have local variables and global variables.
The local variable are applicable to the task (workflow activity) only while the global is accessible at the workflow level.

If you don't initialize your local variable from the global variable, your local won't have the suitable value.

This may be your situation here.

 

Florent ROUSSEL
www.4cad.ca

Re: Workflow variables are getting reset automatically.

Hello @Florent ,

 

Thanks for the response.

 

I have initialized the local variable from global variable, I have no problem in updating the local variable i.e. the workflow activity variable and also this issue does not occur all the time, so far I have encountered only 4 objects with such issues out of hundreds of objects.

 

Regards,

Hari Shankar

Re: Workflow variables are getting reset automatically.

Hi,

 

It seems like at some point, attributes are not getting valued or may be null(Default values set a NULL).

Can you add Logger for these attributes and check the result.

 

In this case you can add isNull Condition for expression Robot(Workflow). 

 

Please refer to the following article: https://www.ptc.com/en/support/article?n=CS273491 for more details

 

Thanks,

Shriram.

Announcements