cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

error when upgrading from 10.1 to 10.2

Highlighted
Participant

error when upgrading from 10.1 to 10.2

Hello,

When upgrading from 10.1 m020 to 10.2 m020 the UpgradeManager fails at the migrator "populate the fields fullname, last and email in the wtuser table".

This is the message in the log file:

Message: There is data corruption which needs to be fixed for the migrator to run successfully
2014-08-31 17:50:34,312 ERROR [UpgradeEventFirer] com.ptc.windchill.upgrade.logging.UpgradeFrameworkLogger - Message: Error in java migrator code:
(com.ptc.windchill.upgrade.updates.directives.directivesResource/27) com.ptc.windchill.upgrade.updates.DirectiveExecutionException: Unexpected error executing a JavaMigratorDirective with className=wt.org.PopulateUserFullNameFields.


Has anyone ever seen this before?


This happened 1 out of 3 test upgrades then it happened on the Production upgrade in which I had to abort.

WinDu showed no errors.



Thanks

Steve


Steven Bugros
Brookhaven National Laboratory
Building 911 B
35 Lawrence Drive
Upton, N.Y. 11973
631-344-3259
bugros@bnl.gov<">mailto:bugros@bnl.gov>

2 REPLIES 2
Highlighted

error when upgrading from 10.1 to 10.2

It looks like you have DS entries or Active Directory entries in the LDAP
that do not have the user's Full Name filed filled in. This is a
requirement in 10.2.
Highlighted

error when upgrading from 10.1 to 10.2

WinRU has a utility to populate these in WTUser table. Appeared after 10.1
M010.




Announcements