cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Anyone else have detailing issues in creo........

Patriot_1776
22-Sapphire I

Anyone else have detailing issues in creo........

.....where showing datums are a complete pain? Sometimes I'll erase a datum (i.e.: A) in a view, and then decide I want it back, and it flat REFUSES to show. At all. I can put the EXACT SAME view (orientation, etc.) with the datum shown, but I can't move the datum to that view. So, I have to put a NEW view in, re-reference all the other child views, to get it to work.

Man, I HATE detailing in creo...... Not only is it a lot slower, more frustrating, and cumbersome, but then I have issues like this........ARGH!


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
19 REPLIES 19

Stupid question Frank... but are you finding the datum in the Drawing Tree and then right-clicking to "Unerase" it?

I've not had a datum go away that I could not bring back. Do you have a sample part- or can you make a very simple part/drawing that exhibits this behavior?

'Morning Brian. Yep, nothing worked. I had to turn all the old projected views into general views, put in a new view where the GTOL datum DID show, then related the other views as projection views to it, then move all the dims. Very tedious, but it worked.

@Antonius: Hah! Yeah, I was ALMOST going to use my symbol......but I honestly was so peeved trying to get it to work that I forgot about it! I'm stubborn, so I just made it work using creo Pro/WORKAROUND and some Pro/FANITY.........

Yep... been there, done that, made my own with the help of forum members

Next you will find that moving the datums around on the drawing will cause a fatal crash.

I have also had drawing corruption where the datum would not physically move until you regen the drawing.

All these things have been reported and no resolution were submitted as yet. Maybe M030.

Well, dwg mode in creo still absolutely s*^(s. Can't get any of the model dimensions I NEED to show. Keeps telling me that there aren't any that can be shown. Total BS. Can't show them via the "drawing tree", the model tree, or picking the feature itself. Complete rubbish......

I can get them to show if I make a NEW dwg, but not in the dwg I already have. Does me a lot of f$&*ing good there, eh? Oh, and another enhancement is, that I can't copy a sheet from another dwg anymore, all I get is about 1/2 the format. Nice job......

Thanks domingo, I will!

Ok, I had to delete the entire 2nd sheet of mydrw, and the views with the other instance, to allow me to show the dimensions I needed, which weren't even shown on the second sheet! Complete rubbish.....

I feel your pain brother! 20 years on Pro-E, I'm ready to quit and retire. This software SUCKS!

Wow Russell, you're one of the few who has more time on the system than me. Bravo!

I have always been a vrey vocal Pro/PONENT (P/UN intended...) of Pro/E, as far as it's power and capabilities go. The GUI changes have done nothing but waste users time. The more experienced the user, the more time is wasted.

Even with Show/Erase button? There is a datums tag and it should list all the Datums in the View and you can check it back on.

There is also a hidden items grouping in the Layer tree where you can remove item from the grouping and will be asked to confirm. It's easier to pick through and select items cause only hidden features elements are collected.

Michael

Yep. The old version of showing and erasing detail items was far more robust. I hate the new GUI for this too......

I see that this is an older thread and it does not look like anyone had any "solutions" to Franks problems. However, we recently "upgraded" to Creo 2.0, from Wildfire 4.0. I just tried helping a co-worker who is having similar problems as Frank in which we have a drawing and model that was started in Wildfire. Both are being updated in Creo. The views in which he is trying to show his dimensions will not show from the "show/erase" menu or any other way for that matter. The only features that show up in the show erase menu are the axis, nothing else. We tried creating a new view and still nothing shows. There are no blanked layers or hidden features that would prevent the dims from showing. We created a new drawing and we were able to show the dims in the new drawing. The only other thing we were able to do was to redimension the features in the model and then the dimensions would show up in the drawing. It's a good thing it wasn't an overly detailed part... because that would have been a pain in the butt. Any solutions to the dimension no show issue?

Mark,

you can try to do following experiment in your drawing.

File > Prepare > Drawing Properties > Detail Options > change

set hidden drawing option user_command to delete_erased_dimensions

This drawing option will delete all erased model dimensions only.

The dimensions can then be shown using the Show Model Annotations dialogue box.

I am not sure if it helps in the drawing created in ProE WF4.

Martin Hanak


Martin Hanák

Nice find, Martin. Where can we find a comprehensive list of hidden detail config options?

Antonius,

unfortunatelly I don't know where to find a comprehensive list of hidden detail config options .

Martin Hanak


Martin Hanák

I like Martin's reply. It makes short work of getting to where you want to go.

The explanation for what you are seeing happen is:

If you look at the drawing tree you will see for each view a list of items related to that view. Identifiers for the erased dimensions should be visible in the tree. They can be erased, unerased (or resumed or whatever the term is today) or deleted.

If they are erased, they will not be visible in the related view. If they are deleted they can be 'shown' which relates them to a view.

If they are already related to a view, they can't be related to another view without moving them or deleting the relation.

Thanks Martin and Dave. I will look into changing that config option. As to the drawing tree, once I found it we did find the "hidden" dimensions, thanks. I will have to blame this one on my lack of CREO experience and the new CREO GUI for hiding the "drawing tree" behind the "layer tree" menu. I'm not used to the "drawing tree" tab. I don't remember using a drawing tree tab in older versions of pro/e. Maybe I'm just getting old and forgetful.

Yup, still having the same old issues. I only need a few dims in my dwg, and it flat REFUSES to show the one I need. About ready to junk-punch a PTC software guy.....

Announcements