cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

Cosmetic thread is not displaying in drawing

cadbart
10-Marble

Cosmetic thread is not displaying in drawing

Hi,

I had to create a thread on shaft so I used Cosmetic Thread feature. Next I've created a drawing with 2 views: first view shows a shaft in top position and the other in non-top position (let's say right side of shaft). View with top position is correct - thread symbol (cutted circle) was created correctly. But view with non-top position does not contain thread lines... Just looks like usual view without any thread. 

Does anybody know how to fix it in Creo Parametric 6.0?


Thanks in advance for all answers!

2 REPLIES 2
StephenW
23-Emerald II
(To:cadbart)

If you Right Mouse Button on a view, there is a "erase cosmetic" and an "unerase cosmetic". In the past, I have accidentally selected the erase cosmetic when I as trying to click something else and lost my threads in that view only.

Make sure the view is a hidden line view (view properties, display style) if its a side view. Cosmetic threads follow hidden lines view settings except in the "end view" which I think is what you are saying calling your top view.

Thank you for answer! 

Yes, I tried hidden-line way but I've got two probmelms with it (we're talking about side-view):
1. In addition to cosmetic thread, another "hidden" stuff which are inside part also becoming visible.
2. When thread is treated as hidden line then it's printed with dashed line (or another defined) on export file (e.g. PDF) not as solid line.

But the most important is the first point. For example, please, look at the picture that I attached in this reply. I'd like to display thread without any other hidden lines.hidden_line_view.jpg   

Top Tags