cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Crash on adding part to assembly

ptc-6792522
1-Newbie

Crash on adding part to assembly

I'm using PTC Creo Parametric 3.0 M010 (The trial verision) and I've been going through the tutorials, but everytime I try to add a part to an assembly the program does a full crash with no explanation.

I've found a partial way around it by using the Assemble->Include rather than straight Assemble, but then I can't actually constrain it.

My video card is fully updated and I can't continue with the tutorials without this being fixed, so I'm hoping someone has the answer. The only other clue I have was I was also crashing whenever I tried to place a hole, which I solved by turning off preview, that's about all I've got clue-wise though.

Also, not sure if this is the right place to ask this question (New to Creo), but after holding for an hour and not getting to the first stage of tech support, I'm not sure if I can handle doing that again.


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
3 REPLIES 3

Try setting the graphics config option to win32_gdi. It's can be in a file called config.pro. If it isn't there it can be added.

Also, what:

Computer maker

Model

OS

Graphics card?

Okay I think I found the correct file: C:\Program Files\PTC\Creo 3.0\M010\Common Files\text\config.pro

There were 4 with that name, but this one made the most sense.

It didn't have a set application to open it with so I went with Word. It gives this text:

drawing_setup_file $PRO_DIRECTORY\text\prodetail.dtl
format_setup_file $PRO_DIRECTORY\text\prodetail.dtl
pro_unit_length unit_inch
pro_unit_mass unit_pound
template_designasm $PRO_DIRECTORY\templates\inlbs_asm_design.asm
template_new_ecadasm $PRO_DIRECTORY\templates\inlbs_ecad_asm.asm
template_drawing $PRO_DIRECTORY\templates\c_drawing.drw
template_sheetmetalpart $PRO_DIRECTORY\templates\inlbs_part_sheetmetal.prt
template_solidpart $PRO_DIRECTORY\templates\inlbs_part_solid.prt
template_boardpart $PRO_DIRECTORY\templates\inlbs_ecad_board.prt
todays_date_note_format %Mmm-%dd-%yy
tolerance_standard ansi
weld_ui_standard ansi
search_path_file $CREO_COMMON_FILES\afx\parts\prolibrary\search.pro

I don't see anything about the graphic config option? If I have to add it to the file, what precisely am I adding?

Also, I tried opening it in Creo Parametric just to check, and it wouldn't do it.

It's a macbook pro running windows 7, AMD Radeon.


Look under Tools/Options

See

http://help.ptc.com/creo_hc/creo30_pma_hc/usascii/index.html#page/pma/fundamentals/fund_five_sub/Abo...

and

http://help.ptc.com/creo_hc/creo30_pma_hc/usascii/index.html#page/pma/fundamentals/fund_five_sub/Usi... for a more in-depth description.

Your best bet for editting is Notepad. The line to add is:

graphics win32_gdi

with a space character between "graphics" and "win32gdi"

Announcements