Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Create dimensions in Creo 3 Drawing


Create dimensions in Creo 3 Drawing

Hi to all,

when i try to create a dimensions in Creo3 (ex. space between two lines) i have to:

1) Click on first line

2) Control+Click on second line

3) Middle botton click

4) Middle botton click if i don't want double value.

Can i avoid 4) step with a option?

Thank you.

Picture after 3) step.


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.


Creating a simple dimension in a Creo 3.0 has become much slower process then it was ever before. Not only that it now takes MORE mouse clicks, it is also necessary to use BOTH hands (one for mouse + one for CTRL key).

Terribly annoying!

PTC is not aware, that detailing was already the slowest process in product development. Not only that it takes hell of a lot time to create a decent drawing in Creo, what is more: it is terribly painfull for your fingers. And this became with Creo 3.0 even worse. I strongly reccomend that PTC R&D talks with somebody who has to work with detailing as his full time job.

Think a little bit, dear PTC, think! CAD software is not only about nice surfaces, importing-exporting fancy 3D models....but is also about finishing 60..80 drawings per week!

Okay, I still haven't loaded Creo 3.0 yet and it really sounds like they messed up a few things in detailing.

Since detailing is half my work effort, can someone please tell me why dimensioning is now 4 steps by posting a video of what the OP is saying? Are there advantages to this that are being overlooked?

It sounds like you need a double MMB to drop a dimension on the page now.

Thanks in advance.

The video below on the learning exchange does show the new dimensioning process:

Thanks, Bill. That helps.

Tomorrow i will post a video. It seem not necessary double click to drop down dimensions. Anyway if you cannot retrieve dimensions from model Creo 3 is a step behind Creo 2. I ll start with production drawing in a few days.

Now that I've seen the propaganda video, I guess I am trying to understand step 4 and the term "double value".

I have no time to make video, but maybe this will be clear enough.

To make a dimension from edge to a hole center:

1st click LMB to select edge

2nd click CONTROL key on a keyboard

and in the same time (here it becomes two hands work!)

3rd click LMB on hole to get a dimension preview

4rd click MMB to place a dimension

5th click MMB to exit dimensioning tool

(5th click is not necessary if you continue dimensioning...but for a single dimension you just have do it)

Thanks... that makes sense. Kind of a persistent menu like the analysis tool.

The new feature on all of this is just the preview right? The rest of it looks the same.

Is there no way to switch back to the old style menu manager which doesn't require holding Ctrl key?

It all looks like a productivity hindrance coming out with a new release once again. A big one this time.

Looking at the learning exchange video, I can see value in much of the improvements.

The persistent menus however need a quicker close option such as esc or picking a new command.

I am not sure what works for closing the dimension menu in Creo 3.0, but the analysis menu in Creo 2.0 is a real PITA.

I've heard that in Creo Parametric 3.0 the annoying measurement menu can be closed with MMB. The drawing dimension menu, that replaces the old menu manager can be closed with MMB as well. So, that is not the issue anymore.

The annoying thing now is that there is a need to press Ctrl key for both. Measurements and drawing dims.

When you measure from say face to a face in a model you have to hold control in Creo 2.0, and I think Creo 1.0 as well. This wasn't the case with WF5 and before.

Anyway lets put aside the measurement tool fact. It's annoying, but I guess people aren't making many measurement throughout the days, so they can live with having to hold Ctrl key, even when it just shouldn't be there anymore because it does hinder the productivity.

It just looks like Creo 2.0 is waay better than Creo 3.0 for some of us, because the problem now is that the same nonsense with Ctrl key is propagated to linear drawing dimensions. Where it has much higher impact for you, if you tend to create alot of drawings, and alot of drawn (driven) dimensions within those drawings.

Just trying to think of the difference there is between the new and old releases. So many questions come into mind. Why Ctrl key? Why is it even there?

Yes for measurements you can, and sometimes you have to pick more than just two objects, but how often? Is there no other way to design the GUI to take that into an account?

When making let's say an ordinate dimension in a drawing, its possible to pick more than two references, and it always worked without the Ctrl key till Creo 2.0. Its not possible to replace references of ordinate dims on the fly in Creo 2.0 because of the old menu manager, which doesn't show the entities picked, but is this just where it's all this GUI development headed?

I bet there is no way to replace references of linear or ordinate dims in Creo 3.0 as well once selected, and I bet it is necesarry to hold the Ctrl key while making ordinate dims in Creo 3.0.

So, this change didn't solve anything other than make the work more painfull. I'm not seeing the real purpose. I'm sure PTC kinda didn't know what they are doing when introducing such change to drawing mode.

Hopefully, I'm all wrong.

EDIT: Oh, and please no Esc key. Not until it stops destroying all the work in IDD.

MMB doesn't close the Creo 2.0 analysis measure tool. Nice that this is fixed.

In general, I only create driven drawing dimensions that are too stubborn to be driving dimensions from the model. Not my favorite way of working but it is expedient. For the most part, I don't like drawing changes making changes to my model dimensions. I would prefer to keep all my model dimensions 4 digit. But when I change them on the drawing, they change in the model. As a long time users, we've pretty much become accustom to that... but it still gets me from time to time.


Can not agree you more!!! It's annoying.

would the Product Manager at PTC for detailing please respond..on this change in detailing?

23-Emerald III

Basically Creo 3 requires two hands and one extra keyboard click to create each dimension. In earlier versions you could just use the mouse with one hand and never need to touch the keyboard. Both of them can exit dimensioning with a middle mouse button click.

Here are links to two videos showing the difference. (I don't have a way to show mouse clicks or keyboard presses on screen.)

Creo/Elements Pro 5.0 (Wildfire 5)

  1. Initialize Dimension Tool - LMB
  2. Create First Dimension
    1. LMB
    2. LMB
    3. MMB
  3. Create Second Dimension
    1. LMB
    2. LMB
    3. MMB
  4. Exit Dimensioning - MMB

Creo Parametric 3.0

  1. Initialize Dimension Tool - LMB
  2. Create First Dimension
    1. LMB
    2. CTRL (left hand)
    3. LMB
    4. MMB
  3. Create Second Dimension
    1. LMB
    2. CTRL (left hand)
    3. LMB
    4. MMB
  4. Exit Dimensioning - MMB

I try to save PTC but i'm not sure. Ok, additional click for Creo 3. Why? I think PTC knows this. In Creo 3 i think ONLY after CTRL button system tries to select second reference for dimension in a zone near pointer. In Creo 2 and previous releases suddenly AFTER first click system tries to select second reference, even if you are far from second reference with the pointer. I hope they did this because searching references near pointer can be quite CPU consuming in large drawing with many model associated. So i think that CTRL has to be pushed as late as possible. I didn't work with very large drawing and i don't know. Certanly for drawings with geometry representation and 20-30 components that CTRL can't be userful.

Searching and speed have nothing to do with it.

It is changed to be consistent with non-CAD software behaviour, even though the consistency causes extra work. For example - pick a cell in Excel. To pick a second cell you have to hold the CTRL key. If you don't hold the CTRL key, Excel deselects the first cell and then selects the second one.

It also means not having to track the state of selections. Force the user to make only and exactly the right number of picks without any feedback and then, when they go to place the dimension, if they chose wrongly, do nothing to indicate why the operation failed. Then there's only one error message required "Could not create dimension"

It's a change pretty much biased towards an occasional user who can't ever remember how is it supposed to function.

I would surely love to hear one (1!) postive opinion about this. One opinion of somebody who works often with drawings and thinks this will improve his (or hers) work!

5-Regular Member

can someone at ptc just go and look at how the other cad packages make dimensions please

ie in solid works if i click on a circle it defaults to a circle dimension

if i click on a rad it give me a rad dim

who in there right mind though hay lets add extra steps in

OK try this one.

make a slot that's on a 45 deg angle with rounded ends "a racetrack"

now make a length dimension that go's from tangent to tangent following the length of the slot

in the new system this is a nightmare


Okay, I've just transitioned from Creo2 to Creo3 and am underwhelmed.

I cannot for the life of me figure out how to create a dimension from an edge to the tangent edge of an arc.

They have really messed up the dimensioning!!!

23-Emerald I

Apparently there is now a toolbar to pick from. I noticed this in the top lefthand corner of the window.

I picked the one that looked like tangent and then it worked.



Well, looks like they have added another mouse click here too...

These PTC engineers need to actually USE this software rather than trying to make it like something it is not.

Everytime they come out with a new version, they add mouse clicks to commands and make it take longer to create anything.

They are contributing to Carpal Tunnel Syndrome, I guess the only way to get their attention is to file a lawsuit against them.

Me, I'm stuck with dims that are all greyed out, no matter what I do.  SRSLY???  What The Frank does THAT mean and how do I fix it????

The issue it seems will be resolved in CREO 5.0..