cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo 1.0 Ribbon Customization

ChrisCollinson
5-Regular Member

Creo 1.0 Ribbon Customization

Gurus



Anyone having this problem,



I'm adding a load of mapkey icons to the ribbon bar in Creo 1.0 m020, I did some last week and saved them of into the admin_creo_parametric_customization.ui file in the text folder - everything worked fine


Today I am trying to add further buttons to the ribbon bar and when I save/export all customizations it looks as if it corrupts the .ui file and I get a strange tab name and none of the new buttons,


Is there a specific way in which to save and export these setting so you can add extra buttons with having to do them in one hit



This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
6 REPLIES 6


I have not tried customizing much in Creo since I like to learn the UI across the board before customizing it any. After a few months, I start to customize what makes sense, but I am not there yet with Creo.


I don't let my users do it either because it makes collaboration harder when someone is trying to help another and can't figure out where things are.


I have noticed that some things work differently than I would have expected and have ran into a couple of things that revert back to normal after a restart. I have not dealt with any corrupted ui files yet, so please keep us posted if you figure it out.


"Too many people walk around like Clark Kent, because they don't realize they can Fly like Superman"

I how found that the file creo_parametric_customization.ui is created in the working directory for every Creo 1.0 session. Deleting this before making new customizations intended for global uses can help.
Right now I am dealing with adding J-Link applications to the Ribbon. It is very confusing. Adding a UI button in the wrong mode makes it difficult to remove again without affecting the UI in other modes. I guess the same behavior can be seen for adding mapkeys.

/Bjarne

What's worked best for me was to save a copy of the ui when I make changes in case I need to revert back, I lost 3 days of customization when I didn't do this. I also make the .ui file read only until I'm ready to save my changes.

Hi,


We have the same problem with the creo_parametric_admin_customization.ui.


After changing something in an existing customization and saving the creo_parametric_admin_customization.ui the file size decreases


from 30kb to 3kb. The same behavior I noticed in Wildfire 3 (SPR 1115524).


A workarround is creating the customization via Toolkit (the toolkit interface saves the ui in a ribbon definition file named tookitribbonui.rbn).


Best Regards


Andreas

We recently migrated to Creo 2.0, thought we had all of our customizations complete which by the way we kept very minimal for now, but found out we were missing some related to skeletons. So we went in and added in what the tab and mapkeys we wanted and lost all of our original customizations or are custom mapkeys turned into smilely faces. To put another twist into this we use a custom launch script that is run everytime a user launches Creo to make sure they have the latest and greatest config files. Below is what it took to get the new customizations added to the original customizations.


- Deleted all UI files on my computer (working dir, text dir)


- Made a copy of the Creo launch .bat file with the line that copies the UI file removed


- Launched Creo with the custom-made .bat file


- Went in to the customize ribbon area and imported the UI file from the network (the one that would have been copied to my text dir if I had run the normal .bat launch file)


- A dialog box came up asking me something, I chose “import for all modes” or something like that (I think “part” is one mode, asm is another mode, etc.)


- I then added the new tab to the skel “mode”


- Exited out of Creo


- Took the copy of the UI file that was automatically saved to my working dir and moved it to the server location (and renamed it appropriately)


I believe the jest of this is that you have to remove any .UI file that exists locally on your box or a users harddrive and once the system/admin .UI is customized push that down onto your box or the users box.

Are you running windchill? There is a copy of the .ui file in the cache there as well.

Andy Hermanson
Engineering Design Applications

tel 605.275.1040 x51114 mobile 605.310.8168
website www.daktronics.com
Announcements