cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Ghosts in PDMLink 9.1

MitchJordan
1-Newbie

Ghosts in PDMLink 9.1

Using Pro/Pipe added 20 hose assemblies to an existing assembly . When I saved the assembly I have 13 new hose assemblies and 7 ghost objects for the other hose assemblies in the Workspace. In session those 7 hoses now are shown as Suppressed and cannot be unsuppressed.

Any ideas?

Thanks


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions

Mitch,

I may have found the root of the problem. I was previously giving the hose assembly and the hose part the same name. Since then, I have created new hose assemblies to replace the ones that turned into ghost objects and have added "-hose" to the pipeline name and the fabricated hose part. So far, none of them have turned into ghost objects although I do get a warning in the event manager sometimes telling me that the assembly was saved as a ghost object and that the "New document in local cache with the name "name of hose assembly" was snapped to server document with the same name". Another one of those cyptic warnings! But after receiving that warning I have closed Pro/E, restarted the computer and reopened the upper level assemblies and all of the hose assemblies are still there.Go figure!!!

View solution in original post

3 REPLIES 3

Mitch,

There are a couple of things you could try:

1. Pick Info from the toolbar, then select the Reference Viewer. You may be able to see and delete the ghost objects there.

2. When you check in the assembly, select Next, then check the box Auto Resolve Incomplete Objects. This should delete the ghost objects, too.

Hope this helps,

Tim

Tim, thank you for replying.

I know how to resolve the ghost objects inside the Workspace. The real issue I hope someone can help with is why 7 hose assy's became ghost objects when I saved the main assembly. All 20 hose assemblies were New in the main assembly and on Save 13 saved correctly into the Workspace and 7 became ghost objects.

Mitch,

I may have found the root of the problem. I was previously giving the hose assembly and the hose part the same name. Since then, I have created new hose assemblies to replace the ones that turned into ghost objects and have added "-hose" to the pipeline name and the fabricated hose part. So far, none of them have turned into ghost objects although I do get a warning in the event manager sometimes telling me that the assembly was saved as a ghost object and that the "New document in local cache with the name "name of hose assembly" was snapped to server document with the same name". Another one of those cyptic warnings! But after receiving that warning I have closed Pro/E, restarted the computer and reopened the upper level assemblies and all of the hose assemblies are still there.Go figure!!!

Announcements