cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

Hatch visible with exclude component

Coin37coin
11-Garnet

Hatch visible with exclude component

Hello,

 

When I exclude a component from my 2D section, I still have the hatch part who are visible.

 

On the properties of my Drawing view, i have selected the "hidden line removal for xhatches" on YES

 

Do you have any solution ?

 section with exclude part and undesire hatchsection with exclude part and undesire hatch section without exclude partsection without exclude part

3 REPLIES 3

I have seen this kind of strange hatching behavior in a few cases:

(1) When I had an interference between one part and another, i.e. I've got a dowel pin that will be press fit in a hole that is slightly smaller than the pin. Or I've made a dumb mistake and have a real interference.

(2) I've redefined the section in the part and Creo isn't really using the new definition correctly. The way I fix this is, unfortunately, to remove the section from the view, then add it again. I think it's because the program has the direction of the viewing vector for the section confused. Used to be more common in earlier versions of Creo.

(3) My section plane was almost, but not quite, perfectly parallel to the view I was showing it in. This was a particularly tough thing to finally figure out. Caused by me making a careless pick for the section plane definition.

Hope one of these helps.

Thanks for your explanation @KenFarley 

 

For what I see, it look like the 1st reason : my male thread are in contact with my female thread ... I don't think I really have an another choice and will continue that way 😞

kdirth
20-Turquoise
(To:Coin37coin)

I recreated the issue in Creo 4.  When I exclude a part in the section after making the drawing view, the view did not update appropriately.  I removed the section and recreated it as Ken mentioned in his second fix option, and the view was correct.


There is always more to learn in Creo.
Top Tags