cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Printing in Creo View

ptc-4332017
1-Newbie

Printing in Creo View

I have a customer that is trying to print a 2D model in CreoView. When he prints is prints in blobs of model. We have tried multiple printers for this user and still it is printing the same. We have tried changing the driver, printing to PDF and they all turn out the same. I have attached a picture of the model we are trying to print and the output that comes out of the printer. Has anyone experienced this before?Original.jpgPrinting from CreoView.JPG


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
24 REPLIES 24

Hello!

Are you using Creo View Express or Creo View Lite (and which service release)?

Express 1.0

Could you attach a example?

The photos in the original discussion are the examples that I currently have. Are they not showing up? I'll attach them to this message for you. Or are you asking for a different type of example? Original.jpgPrinting from CreoView.JPG

The first image is the program showing a drawing. We click on "Print" and the second image is what comes out of the printer. As I said in my original post, we have tried multiple printers, multiple different drivers, and we get the same printout. I appreciate your help. We are going to try and install Creo View Elements 10.0 and see if that gives us the same affect.

I asked about the example file (EDZ) to try to print it.

The EDZ files we have are confidential so I can't provide one for you. Sorry.

Hi Christopher...

Looking at the printout, there are multiple files worth of information being displayed. I see parts balloons and cross-hatching that isn't in your original. I also see parts of the original embedded in there, too. Where would Creo View be getting that extraneous inrformation!? It looks "intelligent" meaning it's not just random stuff tossed into the print.

Have you tried completely uninstalling Creo View, rebooting, and re-installing from scratch. Perhaps a partial install has corrupted the print engine?

Try some of these options... do a print preview. Does the sheet look messed up there, too? Under File>Save Current Set As>Save as Vector to see if you can export the sheet as a DXF. You may also try the Save as Image to try to export a JPEG or TGA.

Sorry I don't have more to offer but perhaps some of those pieces may gives clues to what's happening.

Let us know what else you find out...

-Brian

The top and bottom image may not be the exact file printed, but it happens with every file we print from Creo Express. I've tried printing to PDF with the same result. I've uninstalled and cleaned the registry, rebooted and reinstalled again. Cleared any temp files during that process. Print Preview shows up just fine. I will try to save as vector and image and report my results. Thank you for your input Brian.

Stir up an old thread old here...

When you said do a Save As Vector, I can't find that option. It is exactly what I want to do though so if you could stir me in the right direction here.

All I have under File is Print, Send, Help, Options, and Exit.

Creo View Express 2.0 M030

Thanks

Ok. Did you try to print from other computers?

P.S. Also note that the recently released new service release M020 of Creo View Express 1.0 (http://www.ptc.com/products/creo/view/express/).

I have and they are printing fine. I am using Express 1.0. I will check the release. Where do I find that?

Go to File>Help>About Creo View and this will list the information.

Please see:

Pic_1.JPG

Pic_2.JPG

I am having the EXACT same issue as well... And one other user in my office as well. I emailed PTC support, and have crossed my fingers.

If someone found a resolution, please share.

What type of video card is on the machine you are having issue with?

There are multiple PC’s here with this same issue, so I assume we all have the same or similar video cards…

My PC says it’s an “Intel Q965/Q963 Express Chipset Family”, It’s part of a Dell OptiPlex 745.

This is a really bad bug... it's basically ruined Creo for our entire Engineering department, Many are wanting to go back to another tool, but Creo would be much better if it could print.

Thanks for any help you can offer.

We have had this problem since installing Creo View. We have tried updating drivers, bios, clearing cache, etc... No Success. We are only noticing it on older PCs using XP. Windows 7 seems to be working good.

We have help desk calls into PTC as well. This could have been a great thing for us as we upgraded to Windchill 10.1

If anyone has any success and can eliminate printing the checker boards, please share your success story.

Christopher,

This problem is caused by a bug in the Intel graphics drivers - the CreoView print engine makes use of the graphics chip. If the computer is running Windows XP you can disable graphics hardware acceleration -- which oddly enough doesn't seem to degrade graphics performance, at least not that I've seen. We usually see this problem on Dell computers with Intel graphics.

Try setting the environment variable PV_OFF_SCREEN_SIZE_LIMIT on the client computer to a value of 2048. You will need to close and re-open Creo View after setting this variable, but it should solve your problem.

Brian Geary

http://windchill101.com

I tried changing the PV_OFF_SIZE_LIMIT and it did not work.

Please double check your variable name, the one you typed above doesn't match the recommended name. Setting PV_OFF_SCREEN_SIZE_LIMIT = 2048 has fixed this problem on all of our machines with Intel graphics. This works on both Windows XP and Windows 7.

Brian Geary

http://windchill101.com

We also have had these goofy issues with printing,, Shown above, or blank screen... This started happening when we switched from raster to PDF publishing.

I appears to me that the publisher was set for 300 dpi, and anything above that looks like this as far as viewers go. I finally figured out to change the local PDF viewer/printer to 300 dpi, and this resolved this issue for all users.

I tried to change the dpi to 300 and lower. Still no success.

Do you have Adobe, or Nuance or PDF set up as a system Printer.. i.e. Set up as a printer? That needs to be set up with the dpi at 300. See below image.

If so, run a test by Printing to it with a preview and see if that works.

Just changing a viewer will not do it, from what I have seen.

PDF+printer.jpg

Hi Christopher,


If one of the responses helped resolve your issue, would you please mark it as the Correct Answer?  That way other users visiting the discussion will know; as the correct answer gets copied right below the question.


Thanks,

Amit

Announcements