cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Your Friends List is a way to easily have access to the community members that you interact with the most! X

Republish Out Of Date

BrianToussaint
19-Tanzanite

Republish Out Of Date

So I've gone through and have set up my test system and the properties on it to republish out of date items.  So I changed a component that is used in an assembly.  The assembly doesn't start republishing. doesn't watermark the picture on the Details page and does not even register or show up when you Schedule a job to RepublishAllOutOfDateRepresentations.  I am on Windchill M030-CPS09 with the latest adapters which are M032.  Anyone have any ideas of how to get this to work?


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions

I will have to look into Extended Positioning assemblies.  Seeing that 2 out of 3 assemblies I randomly picked for a test of Positioning Assembly failed because of either an assembly feature or flexed component.

Tech support finally found the property that was off.  It was set back in 2011 for the way we had wanted the system to work when we switched from ILINK 3.4 to Windchill.  The property was publish.markoutofdateonpublishcomplete and it was set to false.  We changed it to true and it started working.

View solution in original post

4 REPLIES 4

You don't have to republish out of date lower level components in assemlbies if you publish the assemlby as a positioning assemlby.

There are some setings in the WVS properties file that need properly set to make it work.  If you open the assembly in Creo View, you should get a message popup stating it is out of date.  If you are not getting this, then you aren't marking them to be out of date....which I beleive is the setting in the WVS properties file.  

Bill,

We are looking at positioning assemblies.  There are a couple of problems with them tough.  One is assembly features and flexible components.  The second is, if you change the length of something, the other components do not update/move with it.  Let's say you make a copper tube longer and it intersects with a tee.  I have seen it update the length of the tube, but the tee and other tubes are now somewhere in the middle of the copper tube that changed.

I worked with someone to set the settings in the WVS properties file.  They are set and they have never seen this.

I do have a call open, but was hoping someone here might have had the same issue or know how to fix.  I posted here because it is specific to this, but the Windchill group has a lot more users.

Extended positioning assembly publishing resolves assembly features and flexed components for us.

In regards to changing the length of something...which area of Creo or Windchill are you making that change on the tube?  It sounds like you have found a way to modify a lower level component and get the other components in the assembly to relocate without regenerating the top assembly in a Paramteric session.

That is concerning that you have the WVS properties files changes incorporated...I would still speculate that if you are not seeing the "out of date" flag in the annotation/represenation table or do not get the popup when opening the assembly into Creo View then you may not have the WVS properties file applied or set correctly.

I will have to look into Extended Positioning assemblies.  Seeing that 2 out of 3 assemblies I randomly picked for a test of Positioning Assembly failed because of either an assembly feature or flexed component.

Tech support finally found the property that was off.  It was set back in 2011 for the way we had wanted the system to work when we switched from ILINK 3.4 to Windchill.  The property was publish.markoutofdateonpublishcomplete and it was set to false.  We changed it to true and it started working.

Top Tags