Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Simp Rep Not Working


Simp Rep Not Working

Hi there,

we are working with Creo3.0 M120 and we are using the simplified representations quite a lot in assemblies to create some partial BOM-tables in drawings or to make our large assemblies less "heavy".

Now we have one part in an assembly which won't be excluded in the simp reps of this assembly.

In the screenshot below you can see that the part is selected and put on "Exclude". But whatever we do, the part always stays vissible in our assembly and drawing.

2017-10-19 10_52_51-2017155-0001 (Active) - Creo Parametric.jpg


Does anybody know what the problem might be? We had this problem once with another part, but at that time we were not trying to fix this problem...


do you have any skeletons with copy geoms or shrink-wraps within the assembly? This will show as two parts one on top of each other.


Hi jbob,

thanks for your reply.

As far as I know, we don't have any skeletons or shrink-wraps.
I've also checked if the part has been assembled twice (on top of each other). But that's not the fact...


I think that part is in some other subassembly, isn't it???

Pleae check "Redefine" option to that simple representation. Right click to the representation name and redefine option.

You will find a Edit dialogue box with two small windows, ''Model tree and model graphics''.

Click on that part in the model graphics window and see the model tree will be opened up to that part...

Please check options for that part in that model tree, 'Exclude or Exclude derived'

Or If possible please share picture of that Edit dialogue box model tree.

I've tried this, but 2 parts are still vissible, even when they are on "Exclude":

Exclude 1.jpgExclude 2.jpg


Even a forced regenerate in the model-player isn't giving any solution...

By the picture it should not be appear in the model and drwaing.

But, Please click on that mark in front of the part, so that mark will be gone.

And it will become ''Exclude derive''

hope so it will work

That mark arrow in front of the part has to be gone.

Please try it

See attached picture

Here might be the problem be, because I'm not able to un-mark the part.

You can see that the mark is still grey... And if I click the mark, it will be black and the part will be on "Master Rep" and if I click another time it switches to "Exclude".

For the other part (the cylinder) it's exactly the same.


Exclude 3.jpg


If I click with the right-mouse-button this menu will appear:

Exclude 4.jpg

123.png1) If assembly of that part is in''Exclude'' then by selecting ''derived'' option, that mark should be gone and that part should become ''Exclude derived'' For an example:------>












2) As per u said, By clicking that mark, It becomes dark and part becomes ''master''.

And by clickind second time on that mark it becomes exclude.

I want to know that, After second click the mark is still there????

If part becomes unmark and it is in ''exclude or exclude derived'', It should not be appear in model and drawing

You can see, if the part is on "Derived" the mark is greyed out:

Exclude 5.jpg


If you push ones on the mark, the part will get on "Master rep" and the mark becomes black:

Exclude 7.jpg


If you push twice on the mark, the part will be on "exclude", and the mark will stay black:

Exclude 6.jpg


There is no way to get this mark (grey or black) away...

I've made a backup of the assembly and i've removed a lot of parts.

In attachment you can find a zip-file with the parts and assembly in it.

If you want to, you can have a look at the assembly 2017155-0130.asm.2

I have tried on that assembly which u shared. What exactly happened to those parts, I dont know.

But after delete those parts and add them again in that assembly, the problem has been solved.

Please try it.

Delete those two parts and add them again in that same assembly and then redifine your simple representation.

those parts can be excluded

Hope it will work.....

I have noticed this aswell. But the problem is that these parts are one of the first parts in the assembly and a lot of parts are assembled on these parts... So that means that I have to re-build my assembly.

Till now, I got only this solution. I will try for some other solutions. If I get something, I will massage you.

The problem is that, these two parts are made ''by default master''.

Generally, If higher assembly is in 'Exclude' then Parts under that assembly can be:


'Exclude derived'

'master rep'

But it can not be master derived.

But these parts are in 'master derived' by default. Reason behind this has to find out

If I get to solution, I will massage u

That's great! We are trying to find out what the problem is too... But till now we haven't found anything.

Thanks for your time!

Try creating a new Sim rep and test the issue. For a trial insert this assembly in a new assembly and try creating a new simp rep. Even force regeneration (Regeneration using model player) may help.

If nothing works, submitting a ticket for PTC TS will help. 

Attention: Creo 7.0 Customers
Please consider upgrading
End of Life announcement here.